2.8" TFT Touch Shield v 1.0 + Arduino Mega ADK R3(android)

Hello all, arduino boards look enticing but im having problems with getting ANY TFT demo to work with the Seeedstudio touchscreen v1.0 from Radioshack with the HC245*** interface chips. The touch sense works fine, but the tft still refuses to display anything but white.

Tried the proper library’s from the wiki, and a few from the forums, still nothing, not even the tic tac toe demo that others have running (although they all seem to have UNO’s)
I have read the readme text files within the libraries and changed the .h files accordingly but nothing seems to get the screen to display anything. This is/should be/ a plug and play shield for an official Arduino board, yes? there is only one way to plug it to the board. I have even gone as far as returning it to radioshack for an exchange but the exchanged one behaves the same way. Before i had the mega ADK, I had the UNO, but had no more pins, so i switched it to the mega. Is there something i’m missing in difference between the mega and the other boards people are having success with the touchscreen? What is the required pin voltages? does the mega have different port mapping with respect to the other boards and the demos written for the touchscreen? The touchscreen was supposed to be arduino compatable, wasn’t it?

to date (about 1 month now), i have not found any demo’s in which the tft will display anything but white on my mega ADK (2560). However i will continue my search through the forums for more clues. As this is my first project on arduino, but i am no stranger to MCU, My background is coming from Parallax Propeller P8X32A and several years of programming, but am new to C++ side.
Thanks for any help,

2.8" TFT touch shield 05A12
MEGA ADK for Android R3

Update: I have dicovered in my haste, i accidentally installed multiple copy’s of the TFT & Touchscreen libraries. It doesn’t really matter the paths, but arduino linked the wrong tft.h file EVERY time i compiled and uploaded. The alternate (wrong) library was in C:\all users…\michae…\arduin…\lib\TFT
I was wondering why when i went to arduino, file, examples" it showed multiple copy’s of TFT examples.

I erased ALL TFT/Touch libraries on my PC, even checked paths in the registry to make sure, then unzipped only one copy of the TFT/Touch libraries and proceeded to modify line 33 to #define MEGA, saved and opened Arduino Studio, tried all the examples and all the examples worked just fine. WOOHOOO!!!

First thing I did was try to speed up the paintScreenBlack() method, which is very slow. Here’s my version:

[code]void TFT::paintScreenBlack(void)


for (unsigned int i = 0; i < 38400; ++i)







It sounds you put your libraries in a wrong path.
Enjou yourself.

Your code is right, just because of limitation of hardware and imperfect of libraries,so we can’t take a flash very quickly.