13.56 MHz RFID module not working(?)

I’m getting results which I can’t understand - I send AA 00 03 25 26 00 00 BB, and when there is no card around answer is AA 00 02 01 84 87 BB or AA 00 02 01 87 84 BB - I don’t know meaning of this and Google doesn’t help a lot. But if card is literally laying on antenna, I start getting AA 00 02 01 83 80 BB - as far as I learned, this should mean something like “No card was found”. I can read serial number of module - it consists only of FFs, when I tried to change it - no answer and it didn’t change. What card/tag am I using - MIFARE ONE S50 card and tag, both for 13.56 MHz and purchased in Seeed Studio. What am I doing wrong? Or is my module defective?

After another day playing with module I’ve come to conclusion that there’s something wrong with antenna. Module answers to all system commands(I can get UserInfo, Version, SerialNumber and so on), but answers for MIFARE commands contain only error messages. So now I have some questions about antenna. Is it just wire(PCB track) of specific length and form, which connects red and black wires? Or is there some electronic stuff(controller or other chip may be?) under the black epoxy? And what should be resistance and inductance reading, when I measured them between red and black wires?

Problem solved, just needed to add capacitor