125Khz RFID reader doesn't work

I bought recently the 125Khz RFID reader (UART version) but it seems it is broken.

I already tried/observed:

  • I can see (with a jyetech scope) a 125Khz signal on ant1 en ant2 connections. This is distorted when a card is nearby (tried multiple cards, all the same behaviour), so I think the tags and RF circuit/Antenna are working.
  • I also looked at the rx/tx pin with this scope, but I only see some garbage during startup and then pulled to Vcc. But no changes in voltage (i.e. no digital signal) when a card is present or not, swiped etc.

What is wrong or did I got an DAO?

:confused: May be you got a wrong one which is Wiegand not Uart… You can try to read the output date as wiegand to confirm it …

I did check that, but there is no digital activity when the unit is powered and a card is presented to the reader (and moved away) it is just pulled to Vcc.

I think the mcu has no firmware or the mcu is broken… Is there a firmware upgrade procedure that I can try? or need to place a jumper or send an init string?

I am sorry that you cannot upgrade the firmware yourself.

to confirm the MCU is not working , you can test the winding connector by a oscillograph , if you can not see the 125K square wave output from circuit , that the module must be broken.