125Khz RFID Module - RS232 Question

I’ve been playing around with the 125Khz RFID Module from the Depot,
but I can’t seem to get the communications working.

The Module detects the tag, flashes the LED, and transmits on the TX
line, but the data coming out isn’t the TAG ID. Instead all I read is a string of
13 bytes valued at 255 each (Not a real ascii character). The 13 bytes is the
correct length for a tag + checksum + start + end.
But the data is obviously wrong. (All high values)

Any ideas on what I’m doing wrong.


We are checking with suppliers about this issue, will update here soon. :slight_smile:

For a little clarity on my setup,

First I had the module hooked up to my Arduino and was just using softserial
to read the input information, and relay it back to my terminal.

After that didn’t work I decided to eliminate the processor from the equation and
hooked the RFID module directly to the FTDI chip for hardware RS232->usb.
That ended in the same result.

So lastly I’ve been playing around a bit with aggressively polling the input from the module
with the Arduino and it seems to be giving me some sort of data, but I haven’t
had time to really look into it any further.

I’ll let you know if I get to figuring anything out.

Thank you very much for looking into it.

Hi dbelieve:

We checked with supplier that they might have mixed a few Wiegand modules to our order, they are identical from looks. :imp:

An Arduino Wiegand library will be posted soon, we are doing the migrating job. This will save uart port on the positive part… However we would provide substitute if you request.

Sorry for the inconvenience brought!

Thats fine. I’ll just wait for the library. I don’t mind.
Thank you very much for your quick response.


Here is the sample code on Arduino, thanks!

seeedstudio.com/depot/datash … 630_WG.pde

Hi, I think mine has the same problem. I tried the same steps as dbelieve did, to no avail.

I tried using the Weigand code, but it didn’t work in my Arduino Duemilanove. I’m new to Arduino, but I can’t see where the pins 1 & 2 (for DATA0 and DATA1, respectively) are being read in the code. I’ll be happy if I can get the Weigand code working, but if I can’t, then maybe we could swap for an RS232 version?



Hi clintfisher
We have valided this code here, would you please check the connection and try it again please?
It’s OK to swap the UART version anyway. :slight_smile:

Hi Sorry, for dragging up an old thread, especially on my first post here.

I’ve just received a Seed RFID and am getting the same issue; I’m getting 11 bytes of 255 when I read.
I’ve tried the Weigand code and get no data at all.

For the serial code, I’m using the simplest of code;

int data1 = 0; void setup() { Serial.begin(9600); } void loop() { if (Serial.available() > 0) { // read the incoming number on serial RX data1 = Serial.read(); // display incoming number Serial.print(" "); Serial.println(data1, DEC); } }

Any help would be appreciated.

One thing to note; the module doesn’t look like the picture on the seeed web site, it looks like this:
but I am told it’s a Seeed product.

Hi Kevin, for the Weigand code you need a different physical hookup as shown on seeedstudio.com/depot/125khz … p-225.html , have you tried that? I tried my Weigand board hooked up as serial and I do get a sequence of bytes containing 255 when a tag is scanned so I think you might have a Weigand board as well.

used your weigand code posted on the other thread
and it works - thanks. It’s a Weigand device not a Serial device.