Page 64 of 70

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Posted: Thu Apr 21, 2016 2:08 pm
by fkossy
I have received it just, and it has hardware version of 2.82

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Posted: Sat Apr 23, 2016 12:28 am
by Amon
Hello,

I wish to thank you for this great firmware which I just loaded on my DSO203. I'm quite new to this so I expect long hours before I can really manipulate it with ease (although since I am new to 'scopes, I have nothing to unlearn).

I wish to report (because I have not seen much on the subject) my experience loading the firmware on a mac (OSX 10.11.4).

My DS0203 is HW 2.81, Sys 1.64.

The USB disk mounts correctly and seems stable
The DFU mounts correctly and seems stable.
To minimize problems, I have disabled Spotlight on these volumes.I also used 'cp' in a terminal rather than Drag and Drop in the interface.

Installing the FPGA was a breeze. Both files copied and gave me the correct results.
However, copying app1.hex gave me an ERR file.
I was able to copy it correctly using VirtualBox and an XP image (and D&D in XP)

Regards,

Lga.

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Posted: Tue Apr 26, 2016 3:14 pm
by Wildcat
V6.0: Bugfix update for V5.0 and V5.1 when used on HW V2.81
Functionally identical to V5.1

Update V6.0: For HARDWARE V2.81 ONLY - Will NOT work on earlier devices.
Fixes issues that are only present on 2.81 devices loaded with V5.0 or V5.1.
V5.x loaded on older HW versions are not affected.
V5.x loaded on HW2.81 using original FPGA may not be affected, since most of these new issues originate from program support of full speed buffer mode, which is only available with the updated FPGA. However, 5.x/2.81 users with original FPGA should still update to V6.0.
V1.1 FPGA included is same as in V5.1, no need to update.

-Increased RAM allocation from 48K to 64K and stack from 8K to 16K. Fixes a variety of potential problems such as loss of meter functions or triggering issues after config file saves. (This breaks compatibility with older devices, which only have 48K RAM)

-Fixed an issue where the program would crash if loading a saved configuration file with a full speed sampling setting while in one of any of the OS modes if the saved configuration contained a long buffer mode XPOS value greater than a certain value.

-Fixed shifting ChA/B DC offset levels after engaging FFT or other functions while in full speed buffer mode, possibly leading to corrupted calibration data if saved.

Any future updates will consist of 2 separate versions: V5.x for pre-HW2.81 units, and V6.0 and up for HW2.81 units ONLY. I have several of the older version devices so I plan on supporting those with the same additions and fixes as the later one, if possible, apart from FPGA based functions such as full speed buffer mode. This will also allow future optimization for the older units, freeing up memory by removing unsupported functions.

For anyone interested, also included a config file reading utility (QUADCFG.EXE). Displays and describes saved configuration and calibration parameters. Built this to help me fix these recent issues with the program. Copy a WPT or CFG file to same directory as utility, type QUADCFG followed by a space and the name of the config file on a Windows command line. Will write a file of the same name but with a TXT extension with the information. If no config file name is supplied or utility is just clicked on, will load first WPT file found in same directory, or just display instructions on the command line if no WPT file is found. Can be used to check for config file corruption or just for informative purposes.
Works with any version WPT "style" file, should also work with early factory apps using WPT config extensions.

Re: HW 2.82 as seen in a recent post: Uses same SYS (1.64) as 2.81, unknown DFU. I would expect this to be compatible with 2.81 updates, but since I don't have a unit on hand, I can't verify. Perhaps some info will appear on the MiniDSO site, but don't see anything there yet...

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Posted: Thu May 05, 2016 2:44 am
by gerard.furtos
hello all,
I just received my DS203 with HW 2.81, I installed WC 6.1 and evrything looks good but when I use the generator at 8 MHZ, the waveform looks like this: (see attachement)
Is it normal?

Thanks for any help.

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Posted: Thu May 05, 2016 3:06 am
by eigi01
WC 6.0 runs fine, but new tool quadcfg.exe didn't work at windows 7. Neither 32bit or 64 bit. Tried to set admin rights but doesn't help. Where is my mistake?

Best regards
Thomas

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Posted: Thu May 05, 2016 6:23 am
by Wildcat
gerard.furtos:
You need to use a faster timebase to properly display 8Mhz. What you are displaying now is just aliasing. You can use full speed sampling to get a better display if you have installed the updated FPGA but you won't be able to discern the individual waves at 2uS/div, all you will see is a filled line.

eigi01 :
All the utility does is write a file on your drive in the same folder you copied the utility to. It does this very fast, and may not look like it has done anything. Look for a file with the same name as a WPT file you have on the drive or the same name as any existing file you have typed after the utility name, but with a TXT extension. If it does NOT find a file, THEN it will write some instructions on the command line, otherwise nothing will show. This is a DOS based program tested on WinXP but I just tried it on a Win7 machine (32bit) and it works fine. Open the TXT file with notepad or any text reader.
Also, if you didn't open a command window but just clicked on the filename from a Windows folder, the window may shut down after the program executes before you can see any message displayed on the command line.

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Posted: Thu May 05, 2016 3:45 pm
by gerard.furtos
Hello,
I am a brand new user and I am not yet fully accustom to manage all functionalities and capabilities given by this device with the new firmware and application, I have to take time to learn and apply.
I know that the time base is to slow to watch a 8 MHZ waveform, it's OK at 0.1 us/div time base, but I don't know yet how to use full speed sampling but that will come.
Thanks anyway for your help.
regards.

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Posted: Fri May 06, 2016 3:43 pm
by eigi01
I have found my problem exeecuting quadcfg.exe. Quadcfg couldn't handle pathnames with more than 8 characters.
In this case there is only shown a message "cannot execute C:\Parameter\QUADCFG.EXE"

Best regards
Thomas

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Posted: Sat May 07, 2016 2:50 am
by motopasscode
I could not run QUSDCFG.EXE on Windows 7 64bit.

Code: Select all

C:\>QUADCFG.EXE
This version of C:\QUADCFG.EXE is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need a x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Posted: Sat May 07, 2016 9:16 am
by Wildcat
For those not familiar with DOS programs such as the utility I posted:
-Filenames are restricted to the "8.3" or 8 main and 3 extension characters convention. The Quad volume is also DOS based and subject to the same limitations, so I did not think there would be any problems.
-Needs an X86 machine, so it will not work on 64 bit versions of Windows, only 32 bit versions. Dosbox is a freeware X86 emulator that can be used on 64 bit Win systems to run DOS programs. There are versions for other OS's also.

Config files are best copied to the same folder as the utility,I have not tried to see if the utility will "reach" files on a path outside it's own folder.

For anyone interested, "example.txt" below is a sample of a file the utility writes.