Page 1 of 1

BB Green wifi unable to 'login' to setup SSID

Posted: Thu Jul 11, 2019 11:37 pm
by curtis.gunderson
Hello - I setup the BeagleBone Green Wireless device through the setup directions. I'm on Win10 and I see the device when connected USB to PC.

I am able to browse to the device as well as use Cloud9 IDE to connect to the device & run sample code to toggle LEDs.

My issue is that when I go to configure WiFi, by connecting my PC wireless or my smart phone to the device's wifi, I see the connect (BeagleBone-B1AE in my case), and it connects. I get a client IP from the device. However -- it does not redirect me to login with SSID so that I can setup the BBGW to be able to connect. At the top, of my client page, there is 'login'. When I click, it gives me error related to 'oauth' or 'err_name_not_resolved'.

I have flashed to the latest image, Debian 9.5 2018-08-30 4GB SD IoT, and have the same issue.

As troubleshooting for standard linux commands, I connect via SSH to the BBGW. I'm able to build a wpa_supplicant.conf file, but when running 'wpa_supplicant -B -i wlan0 -DWext -c /etc/wpa_supplicant.conf' command, I get error 'failed to initialize driver'. I have a green light onboard for the WLAN embedded led.

Any guidance is appreciated.

Re: BB Green wifi unable to 'login' to setup SSID

Posted: Fri Jul 12, 2019 11:11 pm
by curtis.gunderson
I still have the problem but debugged further. I believe the issue is that the beaglebone.local and IPs are not setup in the Domains site. I tried to attached a picture of where someone needs to make changes, but there is an error that the board attachment quota has been reached.

I created my own domain app as shown in the picture. Of course, I do not have rights to the ID in the script, N46nTD88b9rs7E-K0FUAqt8JUi0, to make these changes. When I created my app as shown with the 'nK4F...' app keys and the domains shown, GitHub pop-up window will open and prompt me to login. However, since in my app I do NOT know the response urls, it fails.

I think the solution needs to be that the owner of the 'N46nTD88b9rs7E-K0FUAqt8JUi0' app key needs to add beaglebone.local and/or and/or other 6.2/8.2 addresses in so that github<>oauth will recognize a valid requester.

Alternatively, if someone can respond with the proper response URL for my github application, I can create my own github project to allow me to continue ( I have a second picture of this, but the github field is found by: click on profile icon > settings > developer settings > oauth apps > {your app} > field 'Authorization callback URL' )

Re: BB Green wifi unable to 'login' to setup SSID

Posted: Tue Jul 16, 2019 9:52 pm
by curtis.gunderson
I was able to workaround the login/oauth issue, but I still have the problem with not being redirected to the WIFI/SSID login page so that I can configure & save credentials through the app.

When I connect to my 'beaglebone-xxxx' on the bbgw, it gets connected, I get an IP, but it does NOT redirect me to the SSID login page as shown in the user guide. I've tried from multiple devices, I've enabled popups - removed all browser security actually - which is how I discovered the unrelated oauth issue.

Please assist - is there a device url where I can launch the ssid login screen manually - I cannot seem to find it searching the linux directories.

Regarding the oauth issue...the problem is that the oauth credentials are stored in the github_login.js file on line 10. Since I do not own that credential, I cannot login to oauth/github to update the domain to include .7.2/beaglebone.local as authorized sources. The workaround for me was: create my own oauth app, create my own github app, integrate the two ( ... -for-oauth )...then, replace the token on line 10 with the own created in the process above. Now, when I refresh, and click the login...I am prompted to login with my credentials to github, where the oauth app is authorized, and i get logged in. However...this is not the wifi connection redirect page.

Re: BB Green wifi unable to 'login' to setup SSID

Posted: Thu Jul 25, 2019 1:50 pm
by bill.yu
Hi there~

The factory firmware is included the auth page. You can download it from ... znXRFm1UmP.

The latest image does not include the auth page any more. You can refer to thanks.