Pi 3B 2mic hat not recognized

Applications/questions using Raspberry Pi with Seeed products, please post it here.

Moderators: lily.li, salmanfarisvp, violet

Post Reply
Posts: 1
Joined: Mon May 27, 2019 11:47 pm

Pi 3B 2mic hat not recognized

Post by esmen2406 » Tue May 28, 2019 12:46 am

I have a Raspberry pi 3b - Raspbian Stretch and a respeaker 2mic hat;
It was installed in accordance to the seeed get started process ( april 2019) and worked correctly.
Then after a halt or a reboot ( Don't know) it stopped to work.
There is no recognition of the mic and playback devices by the pi anymore.
Aplay detects only the audio system on the Pi and Arecord detects Nothing.
I update/upgrade the system and tried to re-install the pilots ( uninstall.sh; install.sh) but no improvement. Git clone didn't work as the seeed-voicecard directory already exists.
The leds and the button work correctly.
I saw in this forum that this problem is not knew and was corrected by reinstalling the system. It didn't work here; so may be I missed something or there is something else to do.
Any clue ?

Posts: 735
Joined: Mon Apr 02, 2018 11:05 am

Re: Pi 3B 2mic hat not recognized

Post by bill.yu » Wed Jun 05, 2019 5:27 pm

Hi there,

we build image with alexa/snowboy/drivers installed. you can download the 2018-08-06 image and burn to sd card. you can get the mics work directly. thanks.

https://v2.fangcloud.com/share/7395fd13 ... 13&lang=en

Posts: 4
Joined: Sun May 12, 2019 12:30 am

Re: Pi 3B 2mic hat not recognized

Post by wsteffen » Sat Dec 28, 2019 11:47 pm

Do you have images built on the Buster release of Raspbian?

Post Reply