Seeeduino Lotus + NB-IoT Shield not working

Ardiuno Compatible shields

Moderators:, violet

Post Reply
Posts: 2
Joined: Wed Feb 06, 2019 4:22 pm

Seeeduino Lotus + NB-IoT Shield not working

Post by thomas+seeedstudio » Wed Feb 06, 2019 4:30 pm

I bought a Seeeduino Lotus and a Dragino NB-IoT Shield-B8 but I can not get it to work. I have mounted the shield on top of the Lotus like it should
  • I followed this tutorial: ... o_Mega2560
    I tried the part where you could connect the TX/RX of the lotus to the shield's RX/TX but it does not work
    I connected a USB UART to the debug pins of the shield
    Tried putting a 2A charger to the seeeduino and seeing what it does in the serial monitor via the RX/TX but nothing changes so it is probably not a power issue
I am getting this in the arduino serial monitor when I reset the shield, so it does do something

Code: Select all

And this in the putty (debug on the shield) when I reset it:


The "AT" etc. commands do nothing, does anyone know where I am going wrong?

User avatar
Posts: 85
Joined: Wed Jan 30, 2019 11:51 am

Re: Seeeduino Lotus + NB-IoT Shield not working

Post by bestlux » Tue Feb 19, 2019 10:19 am

the message shows that there is no problem with the connection of TX&RX of Arduino board and NB-IOT shield, as well as the connection of NB-IOT board to the BC95 module. But there is something wrong when starting BC95 board. Could you please try reset the NB-IOT board after Arduino board powered on and post how you connected the circuit. (And have you plug SIM CARD?)
Hope this would help you.

Post Reply