XIAO nRF52 BLE Sense - IMU without mbed-enabled

I own a XIAO nRF52 BLE Sense. I haven’t figured out how to use the IMU (LSM6DS3) without using the mbed-enabled mode.
When I select the device with mbed enabled mode, the IMU works just fine, but not when I select the BLE sense device without mbed enabled.
The main reason for me to use the device without mbed enabled mode is that I can’t use the mbed-enabled mode with FastLED.
What I already tried:
I checked Out the wiring diagram of the XIAO.
I pulled the PIN_LSM6DS3TR_C_POWER manually high, besides it already gets pulled high by the library.
I scanned the I2c address area to ensure I use the device’s correct I2C address.
And the device is recognized but only delivers static data.
I tried all examples in:

The Seeed wiki said about the IMU :

  • The IMU function will perform better when we use the “Seeed nrf52 mbed-enabled Boards Library”, so we highly recommon that.

So it shouldn’t be impossible, right?
What are the differences/disadvantages?

Alternative question:
If anyone can send me a link to a working FastLED fork that works with mbed-enabled mode, that might help as well!

Hi LoadedDice,
See link below 19/23 Dec 28.

I tried this instantly, and this worked like a charm!
Thanks a lot.