XIAO Expansion Board Base I2C - NoPullup/AllAdresses

Hi there, i have 3 Expansion Bords, every single one shows a different behaviour:

I’ll try to read values from 2 Sensors (co2/vdoc and temp/humidity)

One of the boards are showing the right values on the board display, so the code is working…

…but the other one says "no pullup Resistors found, check your wiring. The third one is showing just gibberish and an i2c.scan() brings up 120 (or kinda) active i2c-addresses.

Are they broken? and how? i just put the mcu and sensors on it

i just read that there where problems with XIAO BLE and the Expansion Boards (regulator, 3,3V)

-…i use a nrf52840 Sense for said Boards, so it seems that it could be the bug. what now?

Hi there,

Seems a little wacky for sure, Try to run a couple of the DRAG and DROP uf2 files in the ZIPs from the Xiao Expansion test thread HERE
try the basic ones and see if all three units perform the same.
GL :slight_smile: PJ :v:


the same… 1 working;2 don’t… tried different mcu’s

yep, nRF52840, ATSAMD21

i’d like to try again with rp2040 if they’ll,arrive


Hey, it’s solved:

One of the Expansion Boards is indeed broken: Something with the Power-Management isn’t working and the board is dead.

the other one worked after i resoldered the pin-slots. it’s working fine now.

the third one had no problems whatsoever.

i wonder if it’s just bad luck or if something happened with my delivery, cause the working one was packed in the starter-kit-case and the other ones were loose

Sale is still on! you can get expansion boards too!