The battery charge issue

Are you sure the battery is protected? It usually isn’t. The Quad charger should be and it’s good to see it haven’t blow up already :slight_smile: Just switch the wires and try again. Maybe measure the battery voltage before inserting if it’s OK (this should apply for any battery).

I believe the guys at Seeed tested the Quad well but they didn’t check the separately packaged batteries. Looks like some questionable cheap manufacturer who doesn’t care about polarity… This is serious Beta issue and should be good warning for further products and testing before shipping.


Thank you very much to all of you for your suggestions. As you pointed, the direction was wrong.

I was too stupid, since I was so excited.

I just fixed the way connecting, and now I can run with the battery. Still the gauge shows zero and the backlight is dark. I’ll try keep charging for a while.

I’m not sure, but a simple protection circuit might be available inside the orange part of a battery.


After some soldering and heat shrinking I reversed the JST connector on my battery, and it works! Of course now the leads are too short, so I had to flip the battery over, and the door doesn’t quite close right.

I don’t know how Shiguru managed to plug the connector in backwards. On mine, I couldn’t have put the plug in the wrong way without destroying the socket.

Here is a picture of my temporary fix. (I believe that Seeed will send me a replacement battery soon)


This is an update to the previous post.

Now I can run the DSO Quad with the battery. I charged a few hours, but the battery gage on the screen still show the battery level as zero.

Does this mean the charger IC on my DSO Quad is broken, or not implemented yet?


Looks like i’ve got the same issue as you all.
But mine won’t even power on, i tried USB , Battery and USB + Battery with no luck…
Not even a sign of life :frowning:

BTW you do not need to cut/solder the wire to switch them. With a small screwdriver/knife you can remove the wire from the plastic shell by lifting up the plastic part that is holding it.

I also was given a battery with the reverse polarity. I can now run the DSO Quad off of battery but the status light does not come on when connected to usb with the battery in. If I remove the battery and plug in the usb the status light does come on. Also the battery does not seem to be charging now.

To quote the immortal line from Monty Python - Luxury!

I only wish I had a battery with reverse polarity - Indeed any battery at all would be a step up from the empty space waiting for a battery…

Has anyone else received a Quad without the battery?

I do look on the bright side in that I did receive two probes, which some people seem to be missing.



Technically, the battery polarity ok; red=positive, black=negative. I opened my DSO Quad up and the silk-screening on the board appears to be labeled properly, so it looks like it’s the connector socket that’s been soldered in the wrong way around.

If I have time tomorrow evening I’m going to (carefully) remove the LCD and resolder the socket in the correct orientation. Here’s a photo I took illustrating the problem:

DSO QUAD Battery Connector Bug - IMG_5916 by aplumb, on Flickr

I agree with jnd that there is little chance of internal battery protection. Multi-cell packs usually have battery protection, but single cell batteries seldom have such protection.

Just got my DSO Quad. I was excited and plug the battery in. I then smell some burn and feel some heat near the switch.
It didn’t turn on. I searched Seed forum and found this thread. So I swapped the battery wires and the DSO nano can turn on with the battery, but it has no back light. If I use the USB port, the back light comes up. The battery voltage measured is 3.8v. Anyone seeing the back light after fixing this issue? And what’s your battery voltage please?



By the way, the battery does have a protection circuit on its output. It didn’t suffer any damage when plugged in in reverse with USB cable connected to the DSO quad.

It might be more reasonable and safer to follow Pulsar’s advice in this same thread and just reverse the pins in the battery connector. Then write an indelible felt tip pen warning in the battery compartment.

If you don’t have the proper tools then sure, that’s the safer approach.

The reverse-polarity battery fried my laptop’s USB port when I tried to charge it via the DSO so I’m not feeling as generous as I might otherwise have been. :neutral_face:

It seems my battery is still charging normal after I swap the red&black battery wires in the JST plug.
After leaving the quad off with USB cable plugged in for all night, the battery voltage is measured at 4.3v :astonished: (with a Fluke 179 - should be max at 4.2 only)
However, even with this voltage, the quad still reports that my battery is empty (red empty battery symbol).
Even after all night, the red light is still on.

Anyone has any idea how to fix this, please?

Thanks very much


My only suggestion would be to measure the Vbat signal (between U14 and U15 on the schematic) and see if that is 1/2 the actual battery voltage. If not, then this voltage divider circuit is defective, or more likely, the reverse voltage damaged that input-pin on the STM.

If the STM can’t see the battery voltage, then it will pull down the CHRG output signal and this could possibly force an overcharge condition to the battery and also keep the red LED on.

Does the red LED turn to yel/org when the unit goes to sleep?

I haven’t had a chance to make the board-level fix, but since I’ve already tried charging it in the reversed state it’s sounding like I shouldn’t bother with the battery at all.

I’m leaning toward Minty Boost power via USB. Much safer than an overcharged LiPoly pack!

Thanks for your help.

The STM chip does see the voltage changes. When plugged into the USB port, the charge indicator goes green.
I measured the voltage at R51&R52 bridge, it’s exactly half of the input voltage. In my case, with battery voltage at 3.9v, I measured only 2.6v on top of the R52, thus it’s only 1.3v at the Vbat point. So the STM thinks battery is low for obvious reason.

The voltage at the on/off switch is only 2.6v. The voltage of the battery is 3.9v. So something is lost in between.

Looking at the schematic, I don’t understand why there is an X betwen pin 3 of U19 and the switch? Does that mean pin 3 is not connected?

If pin 3 is not connected then the voltage is passed from the battery solely through the diode inside U19. Is it a Schottky diode or is it a zener diode? I think it should be a Schottky diode. So maybe U19 is dead in my board. If I make a jumper between the switch and the battery, the quad indicates it’s 50% charged.

Could anyone please measure the voltage at the middle pin of your quad’s switch?

Thanks very much


My situation is the same. But I notice:

  1. When QUAD is powered from the “strong” USB port battery meter shows ~4.5V, battery indicator is full and real voltage on battery is 4.08V.

  2. When powered only from battery, battery meter shows 2.85V, scope goes OK, real battery voltage is STEEL 4.08V, battery indicator is empty. So, the battery is OK and fully charged.

  3. When QUAD is powered from the “weak” USB port(e.g. hub), battery meter shows ~3V and battery indicator is NOT empty.

STM measures NOT battery voltage, but something else. May be hardware or software bug.

Concerning the X on pin 3 of U19, my assumpion is that U14 has some king of backfeed inside, which allows battery voltage feed throgh the diod in U19 when not powered from USB.

PS Yes and it is! It measures powerline not battery. In the righ way the divider R51-52 must be connected to point VB but not to the 3V6 which depends on the power status.

And of coarse wrong calibration of the ADC on the PC2_AIN12.

BTW, there is not any cut from U19 pin3 on board.

Just for the record, I “fixed” mine by trimming back the plastic shroud around the battery socket so I could plug it in backwards.

I think the charging circuit’s dead, but I have external LiPoly chargers I can use for topping it up.