(TECH) Unable to falsh Adrunio IDE firmware


I have been trying to flash my unit with the firmware for the Arduino IDE. I am following the instructions on the Wiki (seeedstudio.com/wiki/Arduino … or_RePhone).

  1. I have powered off the unit
  2. Started the flasher (called Updatefirmware.exe in the instructions but is called FirmwareUpdater.exe in the download zip file)
  3. Click the download button
  4. Connect the unit to the USB port
  5. I wait, but no download starts and eventually (about 20 to 30 seconds later I get a slow blink of the green light)
  6. After 1 minute I get a timout message

I am using Windows 7 Pro 64 bit, on an Alienware laptop.

Please advise how to proceed and get the firmware in place.



usb disconnect
rebootshort - no led
firmwareupdater start
choose rephone
klick download
usb connect

if you see flash drive - wrong
if you see com ports - right

thats all

usb disconnect
usb connect
if you see flash drive - drive is empty

now you can upload : RePhone Create Kit VXP
or a aduino sketch
or eclipse …

Thanks for the reply, none of those processes have worked for me.

So I decided to try with another machine. I tried another 64 bit windows machine but no joy. I did finally succeed in updating my firmware with an old Windows XP SP2 32 bit machine.

Once it was updated everything seems to be okay.


my os
windows 10 32-bit
on dell laptop

maybe you habe problems with the
mtk usb debug port and
mtk usb modem port ?

the install program do not work on my system
i must install over device manager and
manual call the inf file
append legacy hardware
and choose the inf file with the explorer

I had the same problem but after several trials an errors now it works - no reason why.

Maybe these advices help to avoid or overcome the problem:

  • install the drivers as admin.

  • be shure, that the battery has enough power.

  • run “\Arduino_IDE_for_RePhone-master\drivers\mtk\UninstallDriver.exe” to repair driver issues.

Good luck!

I’m in the same situation as the OP. Can’t get firmware to flash though. Any ideas?
Hardware appears to working properly. Home screen etc.
Followed driver installation directions step by step.
FirmwareUpdater times out. I’ve tried and re-tried multiple times.

I’m running Win 7 64bit as admin.

Would anyone who has been successful at updating firmware be kind enough to confirm something for me?

When the RePhone is off(solid red LED) and usb connected the device shows up in device manager under “Network Adapters” as “Alcatel Single RNDIS Interface” and driver details shows two driver files in Windows\system32\drivers…sys.

When the Rephone is on(blinking Green LED) and usb connected the device shows up in device manager under “Ports” as “MTK USB Debug Port(COM14)” and "MTK USB Modem Port(Com13).

Is this what you are seeing in your system? I’m trying to troubleshoot what might be holding the firmware update process up and not sure what the cause is.

I’ve also uninstalled and reinstalled the drivers multiple times to no avail.

Thank you for reading.

Any updates from Seeedstudio on a possible cause for this issue or troubleshooting tips that I can try?
I have two RePhone kits and neither of them will accept a firmware update.
Followed the Arduino IDE tutorial and the Eclipse tutorial to no avail.
In both cases the FirmwareUpdater times out showing no progress.
Not sure if this helps diagnose the problem, but occasionally I get this debug error…

Thank you for reading.

Hi bconstructive,

Just now we’ve tried flash the firmware on different operation systems, say win10, win8, win7, win XP, and it all works fine.
We will keep testing and work it out for you.

BTW could you please try this, after successfully installed the driver, connect the Xadow GSM+BLE to computer without the battery connected, then check if you were able to see a COM PORT named ‘MTK USB Port’ , which keeps jumping out and gone in the device manager. This is the port used to flash the firmware.

Best regards,
Chao Zhang

Thank you for replying Chao. I got the FirmwareUpdater to work! It turns out that in my case(Window7 64bit) I needed to manually install the drivers and use the “usb2ser_Win764.inf” file. Now the Rephone works fine and is programmable through the Arduino IDE as well.

It’s a bit embarrassing that I didn’t see that note in the tutorial regarding Windows 7 sooner. Perhaps you might consider [size=150]increasing the font size[/size] on that line in case other people run into the same issue. You also could include it in a troubleshooting guide if you have one going.

Thanks again for getting back to me. Now I’m off to have some fun with my new RePhone :smiley:

Hi bconstructive,

Thanks for the feedback, I will find a way to highlight those keywords :slight_smile:


Hi everyone,
Finally I had success on installing (flashing - on Win XP SP2) the Arduino IDE but now I am stuck on running the “Hello World” example to check if everything is ok.
Here is my steps sequence:

  • RePhone with battery attached and ON (I press the button for 2 sec to turn on, Green light lit up stable), USB cable plugged then:
  • both ports are listed on Device Manager under COM:
    USB Debug Port (Com8)
    USB Modem Port (Com7)
  • Arduino IDE started and under Tools/Port/COM8 - selected (for Debug)
  • Arduino IDE started and under Tools/Board/Rephone - selected
  • upload the example code for “Hello World”, save the sketch
  • click the UPLOAD arrow and the following message appears on the bottom of the IDE: Uploading … and a GREN loading bar on the right
  • the green bar loads close to the end but then it disappear, a white massage appears related to sketch memmory
    but after this it gets STUCK on Uploading … (the green bar not present any more)
  • Arduino IDE set under Tools/Port/for COM7 - selected (Modem)
  • click the Serial Monitor and is BLANK (white space everywhere), I should see the Hello World message every 100 ms.
  • the BAUD Rate is fine 9600 or 115200 (nothing happens at all)

I never get a Uploading DONE message on the IDE (neither after 30 min. of Uploading … status)

Here is the image with the IDE and Uploading …

So did the flashing for Arduino IDE worked? I had the OK message (Download Complete. Your device was successfully upgraded) on the Firmware Updater
If I start the RePhone in the Mass Storage it shows up in Windows and is EMPTY

Any help on getting it working is appreciated, thanks!

Are you switching com ports prior to opening the serial monitor?
Refer to the hello world tutorial. I believe it’s in the re phone for arduino ide guide.
Sketches are uploaded via one port and serial is viewed from another.

If you load the sketch with the wrong port selected it will hang.

Thanks! bconstructive,

Here are my steps: (RePhone with battery and ON (steady green LED) attached to USB, XP will show the 2 new COM ports 8 and 7)

  • open Arduino IDE
  • open the sketch
  • board set to RePhone
  • Tools and set the COM port to DEBUG (COM8)
  • Click the Upload button
  • it shows the message Uploading … and the green status bar on the left but the bar does not complete full 100%, then it shows a text in white at the bottom “Sketch uses 37,896 bytes (0%) of program storage space. Maximum is 10,485,760 bytes.” and the Uploading … message will never switch to Done Uploading
  • Tools and set the COM port to MODEM (COM7)
  • open the Serial Monitor (it is blank) check the Baud rate 115200 is properly set, change from 115200 to 9600 still blank

Theoretically I am uploading and reading the right port but nothing never happens …
In the IDE under Tools/Programmer the default set is AVRISP mkII - we do not need to change this?

Any other ideas ? thanks

I have a trial COM port monitor (Eltima) and it shows some activity on the COM’s either on 8 for Debug when I upload or on the 7 for Modem when I open the Serial Monitor …
but there I can see a ERROR on port 8:
[16/03/2016 14:26:45]
93 IRP_MJ_WRITE - Request transfers data from a client to a COM port (COM8) - 0 bytes of 3
I really want my RePhone :frowning:(( to work in Arduino …

Finally is working but on Win7 x64, probably on XP SP2 there is an issue with the COM ports drivers or something …