Seeeduino Lotus Cortext M0 - 15 Pcs dead after uploading first code

Hi All

I bought 186 Pcs. Seeeduino Lotus Cortext M0+ . Now the serial port of already 15 of those boards is not not to be found anymore.
The Power led is on but I can’t select the Serial Port via: Tools > Ports

These boards worked before.
(I also can not get these 15 board into bootloader mode via doubleclick the Reset))

This is the problem (board/port not found - MAC):
errorSerialPort not found

It is not the Computer or USB cable, same setup with other Seeeduino works perfect - same MAC:

How can I fix this?

My students start to panic, and I can’t blame them. Looks like the Seeeduino is very unstable.
Kind greetings,
Hermanus van Vugt
University of Applied Sciences

Hi everyone, I saw this and it looks identical to the issue I am having with the SAMD chips on Odyssey boards I just received. I thought I would add a link to that topic here. That way if a solution is found for one, it may be applicable to both. Odyssey x86j4105 ubuntu 20.4 no /dev/ttyACM0 and no seeeduino listed under lsusb.



Hi Hermanus,

While my problem was on a different board, perhaps what I figured out will help you. The problem looks to be caused by the seeeduino board library V1.8.0. It breaks the SAMD on my Odyssey. V1.7.9 flashes fine. Per ansonhe97 I have ordered the parts to reflash the bootloader. Hopefully I am able to reflash the bootloader.

Best of luck to you.


Hi @h.e.m.van.vugt

Please try pressing the reset buttons twice very quickly to see if you can enter bootloader mode. This should work on Seeedunio Boards.

Will look into the flashing tool again now to debug. Sorry for this issue caused.

This seems something wrong with the BOSSA uploading tool for SAMD21, we took down 1.8.0 immediately and seems the bootloader mode also got interrupted.

You will need to flash a new bootloader into the ones that can’t find port.

You can use other Normal working Zero board as DAPlink device to flash the bootloader back in Seeeduino Zeros, this is the wiki of how to do so:

Bootloader address:

PLEASE USE 1.7.9 FOR NOW to upload.

Thank you for your reply.

I can’t ask my students to flash a new bootloader, so we have a big problem. They can’t finish their assignments and I have 25 unusable boards. I will contact my supplier how to deal with this.

Kind greetings,

Hi @h.e.m.van.vugt

Sorry for this issue caused.

I got stuck when compiling (this step:".

Settings and error message in the image. How can I solve this?

Complete message:
Arduino: 1.8.13 (Mac OS X), Board: “Seeeduino Zero, TinyUSB, Off”

/Users/harmvanvugt/Documents/Arduino/libraries/Seeed_Arduino_DAPLink-master/examples/simple_daplink/simple_daplink.ino: In function 'void setup()':
simple_daplink:101:13: error: 'class Adafruit_USBD_HID' has no member named 'setStringDescriptor'; did you mean 'setReportDescriptor'?
/Users/harmvanvugt/Documents/Arduino/libraries/Seeed_Arduino_DAPLink-master/examples/simple_daplink/simple_daplink.ino: In function 'void loop()':
simple_daplink:128:17: error: 'class Adafruit_USBD_CDC' has no member named 'baud'
   baud = Serial.baud();
Multiple libraries were found for "Adafruit_TinyUSB.h"
 Used: /Users/harmvanvugt/Documents/Arduino/libraries/Adafruit_TinyUSB_Arduino-master
 Not used: /Users/harmvanvugt/Documents/Arduino/libraries/Adafruit_TinyUSB_Library
exit status 1
'class Adafruit_USBD_HID' has no member named 'setStringDescriptor'; did you mean 'setReportDescriptor'?

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Hi @h.e.m.van.vugt

Adafruit has updated their tinyUSB API.

Please re-download this roll back version of the library for now:

Thank you again.

But I got lost. What should I do after downloading the 'Roll Back Version"?

I can not work with an general description how to use DAPlink. I would appreciate it if you could give me a step by step tutorial how to solve this problem.

Can you make a short and specific step by step description how flash a new bootloader with my specifics in mind:

  • working Seeeduino Lotus Cortext M0 as DAPlink -
  • Seeeduino Lotus Cortext M0 - to be flashed

Thank you,
Hermanus Edward Maria van Vugt
Amsterdam University of Applied Sciences

I am really sorry that we will update all the codes and documents in this aspect after The National Day of China. @h.e.m.van.vugt

Hello @Baozhu,

I hope you had an amazing National Day of China. We have 22 boards that needs to work within two weeks, new students are starting the semester.

Whey can you make an document how to flash a new bootloader?

Thank you,
Hermanus Edward Maria van Vugt
Amsterdam University of Applied Sciences

@ansonhe97 Please update the document.

Hi @h.e.m.van.vugt

Please can you check this wiki here:

Let me know if you have any questions

Hello, I’m having the same problem right now. Somehow 15 Seeeduino Lotus Cortext M0+ boards stopped being recognized by the usb ports after students used it.

I could manage to do this tutorial step by step and use a Seeeduino Lotus Cortext M0+ as DAPlink to flash another Seeeduino Lotus Cortext M0+.

A couple worked again after I flashed it, but I have many more that are not working and I cannot understand why.

If flashing the firmware doesn’t solve the problem, what can I still do about it?

Thank you!
Guilherme Baumgarten
University of Applied Sciences and Arts Northwestern Switzerland