Programming rainbowduino killed my seeeduino


I tried programming my rainbowduino via my seeeduino last night, by following the instructions (and having a blank sketch pre uploaded to the seedunio). The rainbowduino programmed fine, but now the seeedunio is unprogramable.

The symptoms are.
Arduino ide can’t see it or program it.
everytime it is reset, led on pin 13 flashes very fast in a loop forever, immediately after reset.

I tried reflashing the bootloader using the bitbang method, but can’t get past the part where you check the fuses on the seeeduino before erasing.

Does anyone have any ideas as to how I can recover it? would it be possible to reburn the bootloader using a uartSB? or should I try building the parallel programmer to reload it?

what instructions did you follow?

which seeeduino do you have/did you use?

I tried the following

To program originally :

To try bootloader burn, this link is mentioned in the depot for the seeeduino … ex_en.html

I have a v2 seeeduino with the atmega 168.

Cheers for any help

ok, just making sure that is the way you did it. I did successfully burn this way and was able to recover the seeeduino.

what are the error messages when you unplug everything but the usb and just try to load the default blink project onto your seeeduino?

did you use a seeeduino, arduino or another board for this?

I get 3 flashes of the rx light and the message on the ide is
avrdude: skt500_recv(): programmer is not repsonding

I even tried playing with the reset button as I was doing it.

for reference, this was what I was putting on the rainbowduino … Via_Serial

Sorry it was a v1.1 seeeduino I was using not the 2 as earlier stated.

did you switch the reset switch back to automatic? (sorry, had to ask. its got me before)

It’s unlikely you’ve nuked it. It’s more likely the bootloader is just FUBAR. It may be worth using WinAVR (or similar) to read the fuse bits at a low speed to see if you can communicate directly.

Ah yes i did switch it back to automatic afterwards. Could that be what has put it into the current state?

avrdude-GUI can read the Fuses with -P ft0 -F -B 4800, they come out as hFuse FF iFuse FF eFuse 07 Here is the output without the -F

avrdude.exe: BitBang OK
avrdude.exe: pin assign miso 3 sck 5 mosi 6 reset 7
avrdude.exe: drain OK

ft245r: bitclk 4800 -> ft baud 2400
avrdude.exe: ft245r_program_enable: failed
avrdude.exe: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude.exe done. Thank you.

I also tried reading them on my macbook, but couldn’t get the modified code (link) to compile so I switched to trying with my win xp netbook.

Thanks for your continuing help guys.

Yeah sounds like either the bootloader is nuked (unlikely) or something isn’t resetting correctly.

If WinAVR is reading the fuses normally then there’s nothing wrong with the chip. You could try compiling the sketch within arduino and uploading the hex file - that’ll overwrite the bootloader. Failing that, you could upload a new bootloader.

First port of call would be to double check your connections and the autoresetting (as you’ve already done)

Tried recovering with the arduino ide and a parallel port programmer, but to no avail. Ah well, at least it gives me an excuse to get a UartSB now to program my rainbowduino, I’ve been thinking about getting one for a while as they look very useful

Try this method to fix the Seeeduino_v2.12;
Please find the attached file.
fixed as the FixSeeeduino_v2.12 shows.

I’m sorry, please do not use the first attachment.
Please use this one:
put the package to you disk: D:\Program Files…
and direct unzip it.
fix it as the FixSeeeduino_v2.12.pdf shows.
Albert (275 KB)