Possible Reset Boot Loader Problem?

Hello, I have 3 damaged XIAO as well. I am able to upload the bootloader thru SEGGER and a CMSIS-DAP probe but the XIAO does not go into bootloading mode. The Orange LED is flashing fast. I see that the memory gets some code up to 0x2000 which is the proper bootloader size. Any pointer to what the fast flashing orange means ? Thks.

Out of curiosity, can you check what I tried? I think I ran into the same problem and found a janky but non debugger requiring solution

Dear all, I had the same problem with a dead XIAO and found a very simple fix:

for simplicity, I copy the procedure out of the above link:

  1. Press and release the reset button on your board quickly twice. You should now see the LED on the board pulsing, which means the bootloader is running. The double press causes the bootloader to run indefinitely (until the board is reset, powered off, or an upload is done), which means you don’t need to get the timing of the reset just right.
  2. Select the port of your board from the Tools > Port menu. The port number may be different when the bootloader is running so don’t assume you already have the correct port selected.
  3. Start an upload in the Arduino IDE.

The trick is to reset TWICE. As my board does not have a reset button, I simply connected the reset contacts twice (just like a double click with a mouse). Magically, Windows recognized the board immediately.

Good luck, Ludwig