Odyssey x86j4105 ubuntu 20.4 no /dev/ttyACM0 and no seeeduino listed under lsusb

I just got my Odyssey x86j4125 board and installed Ubuntu Server 20.04 on it. No GUI so I’m using arduino-cli. I also am not able to get the Arduino board visible. I don’t think I’m going to be getting a separate tool just to recover the board. I have tried the jumper between the RST and GND pins as instructed here: https://wiki.seeedstudio.com/ODYSSEY-X86J4105/#arduino-ide-doesnt-recognize-the-onboard-microcontroller . Are there any other possible solutions I could try?

Have you ever burned a program to samd21 before, or are you just using it for the first time. Wouldn’t a quick reset samd21 twice in existence help? If that’ s the case, then maybe samd21 was not programmed with the firmware.

Thank you for the response. I’m not 100 % sure what you mean but I’ll try to answer:
I have used Arduino Zero boards before. I have not burned/uploaded anything on the Odyssey board I just received.
By quick reset samd21 twice do you mean connecting the RST to GND twice in quick succession. I tried that multiple times but no change.
If that indeed is the case. What can be done?

Additional info: I have tried two BIOS versions (F and H) and I’ve flashed the newest (M?) EC version.

According to the information you provided, I think it is possible that samd21 does not have a bootloader, do you have a JLINK device, you can manually flash the bootloader we provided.

If you do not have a Jlink device, then you can use another Samd21 device such as xiao or zero for this purpose, please follow the link below

I don’t have a JLINK device.

Would any SAMD21 board work, i.e. Arduino Zero instead of Seeeduino Zero?

It should be work, you can try