No signal after upgrade - how to repair?

Hello guys,
When I switched on my Quad before upgrading it,
it said HW 2.2. Then I programmed these files:
Now it reports HW 2.6, and all channels are dead.
No signal displayed, regardless of whatever I connect to the input.
Voltage is stuck at the minimum. (for example, 8V in 2V/div range)
On the calibration screen, there are all -25 in column ZERO, -1.50 in column DIFF, and +0.00uV in VOTAGE.
What’s happened, and how can my Quad be restored?

Me again…
Did some experimenting. No firmware, I could get my hands on, fixes the problem :frowning:

With 0118 even the function of the keys is different, like the keys were interchanged
between each other. And there is no signal. At boot time HW version 2.2 is displayed.

With 2.30, the keys are working correctly, but there is no signal. All channels are
quiet, the DC level is at the negative maximum. HW version 2.6 is displayed.

With 2.32, it displays “FPGA configuration error”, and fails to start up.

Any idea? What’s wrong with my quad? It looks like the HW version is corrupted,
the firmware cannot decide on which HW is it running on… Help!

the most important of all, be sure the hardware in your hand is v2.6
download the related material and manual at viewtopic.php?f=22&t=1929

“When I switched on my Quad before upgrading it,it said HW 2.2”
you once upgraded it with firmware for HWv2.2?


Thanks for your answer. Yes, most probably I updated my Quad with the wrong firmware,
which was developed for HW 2.2.
Is there any solution to restore it? Updating with the firmware for HW 2.6 does not help :frowning:
(It starts up, keys working, but no signal, all channels are dead)

I’ve uploaded all files again, no change.
Is it possible that the firmware is OK, but the calibration data
is corrupted, that’s why the huge DC offset?
Are you sure, I have HW 2.6?
What is the difference between 2.2 and 2.6? Is the 2.2 schematic
available anywhere? (I have the 2.6 sch only)

and ,pls download the updated firmware include app and sys and fpga ,and have a try
thanks …

Issue solved, downloading the latest FW (1.34 + 2.32) solved the problem.
My Quad is working again. Huh…