Honey, I fried my signal generator?


same thing for me. I also must have mismatched the gnd and signal line of the signal generator and fried it in the process. I actually can’t exactly retrace what I did but the signal generator seems gone. I have actually replaced the 74hc125 in the meantime and it didn’t help. I am not exactly sure what happend, I will have to have a closer look on the datasheet of the chip and the schematic of the dso nano but I guess it killed the output pin of the controller. I think I will do a blog post on that topic soon to share what I found out and also help seed to maybe improve the circuit. It’s really a shame … the DSO is not a bad product but I think there are some serious design issues. A simple protection diode for less then 0.05$ would be sufficient to protect the board and there is enough space left.



A temporary work around for all other users would be to use an audio cable when connecting the generator to the input jack of the Nano; I do this because it is both safer and quicker. The other interim solution would be to never connect the ground lead of the signal-in cable to the ground lead of the generator cable. It is dangerous connecting the signal cable ground to the generator cable ground for if they get reversed then you have shorted out the generator. The Nano circuit board already provides this ground connection.

1 Like

OK, actually I solved my problem at least. It was indeed the 74hc125 which was dead. After I had replaced it I had a bad solder connection therefor I was aware that it worked again.

I will post an description of the problem/solution here as soon as possible, hopefully tomorrow. Hope that will help other people.

1 Like

OK, you can find all information about my fix here in my blog


Have fun!


Hi George,

I couldn’t get this link to work? I got a .com…but didn’t see a blog or post about Nano Fix?



hey danny- im with you lets order some of those buggers from digikey- i think we should test it with the pico to make sure the inputs are getting to the buffer

Yep good idea.Brandon.and be carefull taking the back off and putting it back on…It’s a tight fit …putting the cover back on takes patience to get it to snap in place. Do the probe end first.

There is no problem using the Nano to look at it’s own signal generator circuits. They all use the same common ground and the scope processing interrupts have nothing to do with the signal generator processing. I have tested this to confirm that looking at its own circuits is not a problem as long as you don’t load down the ADC input line while looking at it directly. I didn’t try looking at the ADC input line myself.

I did almost the exact same thing with my signal generator but now when I turn on my Nano v2 I get nothing but a white screen. I’m very sad!! I’ve only had it since March but it’s been my most favorite tool.

Is there no hope for fixing it?

Yup, the same here. Fireworks were great. Opened the can, replaced 74HC125D to 74F125D - just to realize that the signal generator is not responsible for the picture on the screen. Started going with my multimeter from the USB jack down the power lines, found that one of the voltage regulators (U2) gives out half a volt. Took it out, it was OK. Definitely it is the MCU that went dead and. SO I took it out either - USB suddenly announced that there’s a device out there on the line which cannot be identilfied. Surprise surprise, I’ve never yet seen a couple of resistors sucsessfully pretendint to be a USB HID device or a mass storage device or whatever it is. I guess I could find the MCU for some $5 somewhere out here, but my biggest concern is the screen - If it went dead I’ll be unable to do anything with it. Currently I’m looking for ways to test it with STM32VL-Discovery board. But didn’t manage to find the documentation for the screen so far (that’s how I ended up here).

Meanwhile as I can’t live without an oscilloscope I ordered Quad for myself (anyways I’ve always wanted more than one channel). But I can’t imaging how I will be spending those 6 weeks that Russian Post takes to deliver something from the border down here to Moscow.

So my wife just gave me a call and said she’s got two STM32f103VBT6 in her pocket. I will be trying to solder one of them back to the mainboard tonight. I’m just wondering if I will be able to fuse it using USB and firware from the site or it will take JTAG programming?

If the latter, I would be really happy if I will be able to do so using ST-link that I have on my STM32-vldiscovery. If however JTAL is needed I’m screwed.

Dear Seeed support (the forum is called Tech Support - I’ve not invented it!?!). I honestly spent most of my night trying to program the new MCU. My latest result - I manged to download a *.bin extracted from *.dfu taken from package STM32_USB-FS-Device_Lib_V3.3.0 through UART connector on the main board. That connector said to be the only available bootloader in STM32F103 (I read STM manuals). Now when connected the body is detected by Windows as ST Microelectronics Virtual Com Port. I don’t know why I did this - probably because nothing else works. If I try anything else, the device cannot be identified. Please let me know how to make it back to my DSO from scratch. Thanks in advance… I’m just begging for some mercy here I gues…

1 Like

OK, finally got it working (it = MCU). Now I have an “evaluation board” with USB, SPI flash and buttons. Even the signal generator is back to life. The screen however was not lucky as well - only backlighting works that definitely doesn’t help in hardware debugging.

To get the MCU I had to recompile ST’s USB DFU example with some fixes in it. However the DFU mode button (PD9) doesn’t work and I still don’t know how to fix that. I’d appreciate if anyone could attach the original DFU bootloader to this discussion - would save me a lot of time in the first place but may yet definitely help.

I’ll see if there are displays out here for some acceptable price - however I don’t want to spend a lot more on $89 device (already spent some $11 for two MCUs). Specs on the LCD would also help.

At least it was a good way to spend a few days and learn a lot more about bootloaders and firmware flashing while I wait for my new DSO Quad :slight_smile:))

1 Like

Got my screen back. Eventually it was not working because I disconnected the battery. Once I soldered it back (OMG, two wires are so close to each other on PCB without any housing - OUCHHHH) the I saw the image. 99% there with repairment - however one more thing to do. As I connect USB, the screen goes darker and the USB/Battery indicator keeps flashing. The battery is not charging obviously, so I blame the U1 lipo charding IC - I guess it’s dead. As soon as I find replacement I will resolder it and hope everything will be Okay.

If anyone is interested in a “HOWTO” and a DFU bootloader for DSO Nano (V2), let me know. Probably it is already available somewhere but I didn’t manage to find one and had to compile myself.

1 Like

Andrey, quite some endeavours you went through there, great that you got it working again. Thanks for sharing the experiences made! If you for any reason would like to reflash the original boot loader, here goes.
dsonano2-loader.bin.zip (8.26 KB)

1 Like

Great tormod, thanks! That was a real fun for me. Eventually I managed to waste completely the power part of DSO, so I just use it by supplying 4V to the switch directly from a standalone power supply. Anyways, I don’t need more for now.

By the way, if I were in the same situation and would need to solder a new microcontroller into place, I would consider replacing it with a pin-compatible model with more RAM for the sake of hacking :slight_smile: What about running uClinux on it* :slight_smile:

*Ref: AN3012

Hi tormod

The link to bootloader has died. Can you please upload it again? Also, is that possible that I also upload it somewhere?


I have reuploaded it. I don’t know the terms for distributing this data, but I guess it is OK to let Nano owners reflash it.

Hi. I fired it too. After replace CPU I need origin bootloader. Link in post no longer valid. Where I can find it?