DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes)

Thanks for the consideration, Wildcat.



I rewrote my little sticky note list of configs, as I reset my configs and reordered them. I’m thinking of laminating that sticky note. My DSO203 came with a nice little pouch so I have the sticky note there.



Automatic saving? Seems a bit too… If you set this up, then I’m sure there will be others asking you to give them the option to turn it off. (I would)



Changing the shortcuts? I’m used to this DSO by now. So you’re right. I wouldn’t want it. Unless it was obviously superior and ergonomic.

The more I thought about this the more I believe it would be very useful, not only for configs but all file formats. So started work on new file access routines. Working on a directory list function, hoping to implement a pop up display of filenames to load and a “writeable” save function so files can be renamed while saving.



Thinking about possibly displaying the present config name in a vertical row at the top left of the screen, under the cursor/channel pointers, just below the battery icon (about the only place available…) Also, no reason to limit configs to only 10, this was done so a single digit would fit in the display.



Only in the very early stages of this, running into some weird restrictions in the rather simple file access of the system, like only supporting filenames with 7 characters + extension, so renaming may be mandated to have 7 chars. Will be working on this (and a few other minor updates) as time and health permits.

Wow. The prospect of this upgrade makes me speechless, Wildcat. It is beyond awesome. You would, yet again, take this scope to a whole new level of usability. I don’t need to tell you this, but, please, take as long as you need on this! There is no urgency here.



But I definitely appreciate how elemental you have been. When I needed the inverted function, you came through, and that was no small upgrade. So thanks again.

Testing to see if I can get this topic into current forum

Update V5.3 / V6.2:



-Added file list and file name editing directory functions. Filenames for all types can be created and filelist displayed.

-Fixed Delta T/freq cursor display not working correctly while in chart mode (did not work after changing chart mode to oversampling). Delta time display over 120 sec. will now display in minutes.

-Fixed FFT to update properly while in hold mode at the slower timebases or after loading BUF file.

-Eliminated the delay at the end of auto reset used in persistence mode.

-Changed VDC meters to read inverted value if in ChA or B invert mode with OS buffers rather than non inverted input value to bring in line with rest of meter displays while in invert mode.

-Changed “save IMG” to “save ROM”. This saves a 512KB binary image of the complete ROM, including bootloader, licence, SYS, all apps, FPGA and logo in .BIN format for restoring device via internal header if ever necessary. Filename is set to ROM_IMG.BIN and cannot be changed. Apparently, some users thought this saved a different kind of “image”. Make sure enough space is available on drive before using this, specially on 2MB devices, if there isn’t the system’s file access functions leave the failed entry behind and uses up the remaining space.

-Removed the requirement for early (2MB) units that CFG files exist before they can be written.

Both versions still leave slot 4 open for an additional program, as well as the area at the start of the second half or the ROM where Alterbios and Pawn store some code.





Some notes on new directory functions:



-Select file type first in file menu to be displayed in list for loading or to edit name before saving.



-Read dir list or access filename edit function with file sub menu (button 4) (file save/load > file number > file type > dir list/name edit) If file load is selected list will be displayed, if file save is selected filename edit function will be displayed.



-Files are listed in sequence found in file allocation table.



-Select file to load in list with left toggle, press center button to load blinking highlighted file. List will scroll up/down when reaching top/bottom. Right toggle can be used to quickly shift list one page up/down at a time for reading large number of entries.



-Last loaded file will remain highlighted in list as reference until extension type in file menu is changed.



-BMP and BUF file selection will advance for quick loading in sequence with left toggle center or previous with right toggle center as with original number system.



-Before saving, edit filename with left toggle to change characters, right toggle to select next/previous character. Press center left toggle to save. Config files can be saved with button 3.



-Characters available are, in sequence: misc symbols > 9-0 > space > A-Z with spaces as default. Short press right toggle center button to reset selected character to space. Long press right toggle center button to reset all characters to spaces.



-Spaces can be left in name, the program will change mid-name spaces to underscores and remove all leading spaces to be compatible with DOS file naming.



-Fully compatible with previous file numbering system, old numbering system still functional.



-Config files selected from list will have name displayed in a vertical row at top left of screen, except in spectrograph and MAP modes. Numbered config files loaded in previous manner will only show number in original place in notification area under Ch C menu.



-Boot config 0 will not be displayed in list, as this is actually a WPT file. Save/reload this in original fashion since it uses the device’s serial number as file name.



-If files are named from a Windows PC, any file name containing mid-name spaces or of greater length than 8 chars will write an additional long filename entry in the Quad’s file table, and while these will be displayed in a Windows machine, only the DOS version with show in the program. These are abbreviated and end with a tilde “~” which will be displayed as a dot in the list, followed by a number. Any other allowed filename characters not in the Quad’s character table will also be displayed as a dot.



Please be aware that the program size for both versions has grown to a point where if loaded onto the wrong hardware version, it will attempt to overwrite some part of the system area. Specifically, if V6.2 is loaded onto pre-HW 2.81 devices, it will overwrite the FPGA, which will require it to be reloaded. If V5.3 is loaded onto a HW 2.81 or later device, it will attempt to overwrite some system code on the second half of the ROM. While there appears to be some measure in the DFU to prevent this from happening, I can’t guaranty this for all DFU versions, and could require the DFU to be reloaded via internal headers. MAKE SURE YOU ARE USING THE CORRECT VERSION FOR YOUR HARDWARE!







V6.2 FOR HW 2.81 AND LATER ONLY=

http://www.files.com/set/57bd47692fff4



V5.3 FOR OLDER DEVICES PRIOR TO HW2.81 ONLY=

http://www.files.com/set/57bd46f9a637e



The attachments below don’t seem to work any more - download from the above links.

Hello,

I have tried to update but when restarting the dso, the application version is still 6.1,

what can I do to solve this problem even the application is well loaded?

My DSO is :

SYS 1.64

HW 2.81



Thank you for your help in advance.

Something must have gone wrong with the way it was updated. Just to make sure, I just downloaded V6.2 I posted from the forum and loaded it onto a device with the same HW and SYS version as yours which I reverted to 6.1, and it updated fine…



There have been some issues with later versions on Windows having trouble with copying these files to the DFU. If you have one available, maybe try another computer. There are a number of recent posts in this thread that deal with this problem. Make sure you extract the files with Winzip and not from a Windows folder created from the Zip archive. Look for the RDY file after uploading.



I have had problems myself with what I believe may be dirty USB contacts, sometimes after uploading, with a unit that has been sitting around for a while, the DFU volume does not reappear. After shutting the device down, working the USB connector in and out a few times and reloading, it then works fine. Haven’t tried to start the device before re-uploading when that happens, just assumed the upload failed, so I don’t know if it would have just started the previous version or not…

Thank you very much for your fast answer, I have used WinRar to extract the archive and after that every thing is OK.

Now the revision is 6.2 as expected.

I will investigate this new version and will report the result.



Thanks again for your help.

Regards.

What I have tested so fare is OK for me, I will test deeply later.

Thank you for this new version.

Regards

I have successfully installed 6.2 on mine.



I haven’t tinkered with everything… BUT, MAN, I LOVE YOU.



This new load config menu list is great. I also love the clever way of listing the config name vertically on the left side.



This is just totally awesome!



Saving and naming configs are easy.



And I’m sure this only scratches the surface.



I can’t even begin to thank you. You’re like a mathematical genius Santa Claus.



THANK YOU!

Does anyone have Wildcat’s V6.2 available? Can’t download. This forum is getting really messy. Seeed has done a good job of screwing this up.

Was just on the new forum trying to sort things out when an admin posted that the old forum was up again…



Just finished an update to V5.3/6.2 which I will post shortly as V5.4/6.3, possibly tomorrow if everything goes right (to an external link apparently, since I can’t download from this site either). This adds a file delete function to the editing and listing plus some other minor changes.


Thanks a lot Wildcat for your reply. I couldn't get to the forum for days (i didn't know when the old forum went down exactly) so i messaged them everywhere, facebook, twitter, email, contact form, new forum etc..and they got it fixed.

For anyone wondering here is the post for anyone interested (regarding saving data to a CSV): http://www.seeed.cc/topic_detail.html?id=6023
I'll need to read it again, and test some things but i mostly got the answer i was looking for. For reference the waveform i posted correlated to the current passing through a shunt resistor. Integrating the data to find the area under the curve will give you the total charge and you can calculate the energy dissipated through the resistor. This function can potentially be implemented in the firmware if technicalities allow it for people to measure for example battery cell capacities.

Also it seems it is a partial fix just for this thread as you can't actually access all of the old forum - it redirects you to the new forum.

I am not sure even if it is a good idea making a new thread though - the new forum is missing features - the old one is about to die :/ Seeed really needs to fix the features first in the new forum and then transfer all the data to the new forum if possible, or at least archive the old forum so we don't lose all the info!

Will be a few days before I can finish a new update (just basically adds a file delete function), in the meantime I added external links to V5.3 and 6.2 on the original post on the previous page, since the uploads don’t seem to work anymore.



Please read the information on the post, make sure you are using the correct version.

I must say, ever since the last update, I have been looking forward to using this device and adding to the small but growing library of configs that I have been naming and collecting. The ability to name the configs has been wonderful.



I needed to have these configs set up beforehand because when I need them at all, I don’t have the time to sit around, think, and try to figure out what settings would be best for the particular work I’m trying to do with the probe. And now… I just pull out that list on screen and, Boom! Ready to go! Truly wonderful.



Can’t thank you enough, Wildcat!

You’re welcome…



I want to take this opportunity though to warn users of a potential serious issue I’ve just discovered regarding the 8MB drives: as it stands, if a file write is attempted while the drive is full to the extent that there isn’t enough room left for it, the internal system file functions “loop around” to the beginning and destroy the file allocation table, rendering the drive unreadable until reformatted.



This was tested on a HW 2.81 device with SYS 1.64, and looking at the source code, appears to exist will ALL SYS and APP versions, including the factory apps. The 2MB drive devices do not appear to be affected, at least when used with Alterbios, possibly because the smaller sector size of these need the entire file table entries to fill the drive.



The next update will be posted shortly and will monitor system file writes to prevent this from happening. In the mean time, I would advise keeping an eye on your drive to make sure it’s not getting full.



Not sure if any users have written enough files on these drives to fill them up, given the small size of most of them, but some BMP’s and CSV files do take a good amount of space. Also, in the mean time beware of the “auto save” function in the chart mode which could fill up a drive if left unattended…

Posted V5.4/6.3 update on the new forum. Will be posting there from now on, since it appears this one may be short lived.

<LINK_TEXT text=“http://www.seeed.cc/DSO-Quad-community- … -6071.html”>http://www.seeed.cc/DSO-Quad-community-edition-Wildcat-updates-t-6071.html</LINK_TEXT>

I cant find any working firmware download anymore. Everytime I get 404.



I have a DSO203 HW2.72. I need FPGA firmware and the right APP.

Unfortunately, the new seed forum, where wildcat posted his releases, is not more existing. And, this is sad, wildcat

passed away. But MotoMaxis put the latest source to github.



https://github.com/MotoMaxis/DS203-DSOQuad