DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes)

V6.0: Bugfix update for V5.0 and V5.1 when used on HW V2.81

Functionally identical to V5.1

Update V6.0: For HARDWARE V2.81 ONLY - Will NOT work on earlier devices.

Fixes issues that are only present on 2.81 devices loaded with V5.0 or V5.1.

V5.x loaded on older HW versions are not affected.

V5.x loaded on HW2.81 using original FPGA may not be affected, since most of these new issues originate from program support of full speed buffer mode, which is only available with the updated FPGA. However, 5.x/2.81 users with original FPGA should still update to V6.0.

V1.1 FPGA included is same as in V5.1, no need to update.

-Increased RAM allocation from 48K to 64K and stack from 8K to 16K. Fixes a variety of potential problems such as loss of meter functions or triggering issues after config file saves. (This breaks compatibility with older devices, which only have 48K RAM)

-Fixed an issue where the program would crash if loading a saved configuration file with a full speed sampling setting while in one of any of the OS modes if the saved configuration contained a long buffer mode XPOS value greater than a certain value.

-Fixed shifting ChA/B DC offset levels after engaging FFT or other functions while in full speed buffer mode, possibly leading to corrupted calibration data if saved.

Any future updates will consist of 2 separate versions: V5.x for pre-HW2.81 units, and V6.0 and up for HW2.81 units ONLY. I have several of the older version devices so I plan on supporting those with the same additions and fixes as the later one, if possible, apart from FPGA based functions such as full speed buffer mode. This will also allow future optimization for the older units, freeing up memory by removing unsupported functions.

For anyone interested, also included a config file reading utility (QUADCFG.EXE). Displays and describes saved configuration and calibration parameters. Built this to help me fix these recent issues with the program. Copy a WPT or CFG file to same directory as utility, type QUADCFG followed by a space and the name of the config file on a Windows command line. Will write a file of the same name but with a TXT extension with the information. If no config file name is supplied or utility is just clicked on, will load first WPT file found in same directory, or just display instructions on the command line if no WPT file is found. Can be used to check for config file corruption or just for informative purposes.

Works with any version WPT “style” file, should also work with early factory apps using WPT config extensions.

Re: HW 2.82 as seen in a recent post: Uses same SYS (1.64) as 2.81, unknown DFU. I would expect this to be compatible with 2.81 updates, but since I don’t have a unit on hand, I can’t verify. Perhaps some info will appear on the MiniDSO site, but don’t see anything there yet…

hello all,

I just received my DS203 with HW 2.81, I installed WC 6.1 and evrything looks good but when I use the generator at 8 MHZ, the waveform looks like this: (see attachement)

Is it normal?

Thanks for any help.

WC 6.0 runs fine, but new tool quadcfg.exe didn’t work at windows 7. Neither 32bit or 64 bit. Tried to set admin rights but doesn’t help. Where is my mistake?

Best regards



You need to use a faster timebase to properly display 8Mhz. What you are displaying now is just aliasing. You can use full speed sampling to get a better display if you have installed the updated FPGA but you won’t be able to discern the individual waves at 2uS/div, all you will see is a filled line.

eigi01 :

All the utility does is write a file on your drive in the same folder you copied the utility to. It does this very fast, and may not look like it has done anything. Look for a file with the same name as a WPT file you have on the drive or the same name as any existing file you have typed after the utility name, but with a TXT extension. If it does NOT find a file, THEN it will write some instructions on the command line, otherwise nothing will show. This is a DOS based program tested on WinXP but I just tried it on a Win7 machine (32bit) and it works fine. Open the TXT file with notepad or any text reader.

Also, if you didn’t open a command window but just clicked on the filename from a Windows folder, the window may shut down after the program executes before you can see any message displayed on the command line.


I am a brand new user and I am not yet fully accustom to manage all functionalities and capabilities given by this device with the new firmware and application, I have to take time to learn and apply.

I know that the time base is to slow to watch a 8 MHZ waveform, it’s OK at 0.1 us/div time base, but I don’t know yet how to use full speed sampling but that will come.

Thanks anyway for your help.


I have found my problem exeecuting quadcfg.exe. Quadcfg couldn’t handle pathnames with more than 8 characters.

In this case there is only shown a message “cannot execute C:\Parameter\QUADCFG.EXE”

Best regards


I could not run QUSDCFG.EXE on Windows 7 64bit.

</s>C:\>QUADCFG.EXE This version of C:\QUADCFG.EXE is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need a x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.<e>

For those not familiar with DOS programs such as the utility I posted:

-Filenames are restricted to the “8.3” or 8 main and 3 extension characters convention. The Quad volume is also DOS based and subject to the same limitations, so I did not think there would be any problems.

-Needs an X86 machine, so it will not work on 64 bit versions of Windows, only 32 bit versions. Dosbox is a freeware X86 emulator that can be used on 64 bit Win systems to run DOS programs. There are versions for other OS’s also.

Config files are best copied to the same folder as the utility,I have not tried to see if the utility will “reach” files on a path outside it’s own folder.

For anyone interested, “example.txt” below is a sample of a file the utility writes.

Just for information, where did you find the module QUSDCFG.EXE ?

Is it a program to configure the DS203? Or just to whatch the configuration?

Thank you for any answare.

Hello WildCat. I found an issue with chart mode and long time base - 5-10M. In this mode I want to make graphs of discharging batteries, but after few minutes all readings drop down. Tried with both channels A&B, only A, only B. This is happening with all buffer modes with time base more than 1M. At 1M there are a small spikes that can confuse my readings.

This problem is since WC5.0, now with 6.0 is the same. I need both channels for measure voltage and current of discharge.

Is there a cure for this?

Not sure what the drop down to half level is shortly after the beginning of start is in the second screenshot, but both displays show shutdown after approx 10 mins.

Looks like the program is going into standby. After a 10 min. time span of not using any of the controls the device shuts down power to the scope front end and puts the processor in standby mode. Only the generator part will still function at this point. To disable the standby timer, first shut meters OFF, then long press right toggle (button 6). A notification at bottom of screen will display “standby timer off”. The timer can be turned back on by long pressing the button again. Plugging a charger into the USB port will also disable the timer while the USB cord is plugged in. I should have pointed this out in the user guide while using chart mode with long time periods.

Note that this setting is NOT saved with a config file, the program defaults to “timer on” every time it is started, so this will need to be changed again after a restart if necessary. Also note buffer mode defaults to normal while in chart mode (no oversampling), and setting A & B trig mode will force the mode out of TrOFF and into NORMAL

As far as the spikes on your display, I would guess this is likely noise picked up from interference. I would disable the generator output (your screenshot show it set to PWM, change wave type until it shows “off”). Any connection to the power line, such as to a ground from a charger, etc, can make the device MUCH more sensitive to RFI (such as motors turning on, etc), and can produce spikes of this nature. Otherwise, can’t really say, could be a number of things. Operating any of the controls can produce noise on the display. You could set up the scope in a faster time base, perhaps with one of the oversampling buffers types, and use the persistence mode, which will “record” any spikes if set to “continuous” to get a better picture of the noise, this might help identify it.

In any case, it’s something picked up by the scope’s preamp, whether it’s part of the signal you are monitoring or not.

OK, first screen is on battery with sleep timer off, second is on charger. In both cases readings drop down long before first line of the grid (10min).

Can I ask you to try this setup with your device? A simple Li-Po battery or other DC source, connected to probes with 10min timebase.

Ok, when I first looked at your first screenshots, I thought the problem was that the level was dropping down to 0 after ~ 10 mins, I didn’t notice the cursor on top indicating this was just as far as the readings had advanced, that’s why I suggested the standby timer. So the problem is the drop down to around 1/2 level.

I just let one of my devices run at 10M/div with these settings for around 40 mins, and although I didn’t get any drop in level, when first started the level was wrong, at about this 1/2 level, as if perhaps the range hadn’t been updated properly. After shifting the timebase to a faster position, it corrected itself. This may be related to what you are experiencing.

I will check this over to see what’s going on… I need to know what versions you are using. Presumably, since you loaded V6.0 of the program you have hardware 2.81, I need to verify this. I also need to know what FPGA version you are using, factory, V1.0 as included in the APP 5.0 or V1.1 included in APPS 5.1 and 6.0.

First one is taken after purchase of the device, no mods. Second is with latest WC6.0. FPGA is from 6.0. Before that there was 5.1 with FPGA from it, same problem. Never tried 5.0.


I bought a brand new DSO203: Hardware 2.82, SYS Ver 1.64, Serial No 792BD89A).

I tried to install Wildcat Version 5.1 => but uploading app1.hex via DFU results in app1.err.

So I uploaded FPGA_281.ADR, 281_FPGA.BIN and app1.hex (all Wildcat 5.1)=> uploading is perfectly done => but restarting dso hangs in splash screen showing “FGPA configuration error

After that I tried these configurations without success:


Uploading to DFU always looks well

Thanks for the feedback. I have used the chart mode extensively, but always at the faster timebases, so never noticed these issues. Checking all possible combinations of the different functions on this program is rather time consuming, I rely on feedback from users to pick up on what I may have missed.

Did a fair amount of checking over the software and running tests on this, it appears that the ADC simply doesn’t work reliably when clocked at speeds of less than 1Hz or so. (clock rate at the 10Min/div TB is 1/20Hz). This is not too surprising, given that the minimum recommended signal to noise based conversion speed rating of the ADC is 1Mhz! Nonetheless, all ADC versions seem to work well at 30Hz (1Sec/div). I suspect the limitation here is in the sample/track and hold front end in the ADC chip, which under these conditions is asked to hold much longer than it was designed.

The “glitches” in your first screenshot may also have been caused by this. I have a different version ADC in mine, which could explain the somewhat different results.

The way to fix this is to oversample the chart mode (presently the regular OS functions are disabled in this mode). The hardware is already setup for this in V2.81 when used with the FPGA that comes with 5.1/6.0 so it should be possible to get around the problem by raising the clock speed this way. This would also improve on signal acquisition, since many more samples would be taken. Averaging and peak holding could also then be selectable , as in the regular timebases.

Unfortunately, for devices prior to HW 2.81, the factory FPGA that comes with these doesn’t support oversampling, and since the FPGA chips in those are from a different manufacturer (now out of business) I cannot reprogram them. The range on these older devices may have to be restricted to speeds that work reliably.

EDIT: hardware (FPGA) OS functions have proven not well suited for slow chart speeds, so a software function was developed instead. This will also be included in 5.x versions for older devices.

Will be working on this as time permits, and post an update once a fix is implemented.

I have no way of verifying operation on devices other than up to 2.81, neither can I find any info on HW 2.82

Some suggestions:

-Older versions of Windows (XP, 7) seem to be more reliable for upgrading. What is the DFU version ? (shows on screen when updating). Later versions of Windows are fussy as to which version the DFU is. Also it’s been reported that turning on the device before plugging in the USB is more reliable on later Win versions.

-A directory on your PC screen shows both app1 and FPGA being updated. I have always updated the APP and FPGA separately, shutting off the device and re-connecting the USB in between. It appears that you updated BOTH APP and FPGA at the same time. I don’t know if there is a problem in doing this, I have just never tried it. You may want to try just uploading the APP hex file, then disconnecting and then starting over again and upload the ADR file, wait for the volume to reappear then copying the FPGA BIN file.

-Use Wildcat version 6.0 rather than 5.0 or 5.1, there have been some issues with versions 5 when used on HW2.81.

Thank you very much, Wildcat. I will wait for update.

Thank you very much WC.

Your advice was right.

I went to my neighbour, who has a computer running windows 10.

I uploaded FPGA_281.ADR, 281_FPGA.BIN and app1.hex from WC6.0.

5 minutes and the problem was solved.



I realize you have HW2.82, but it looks like your problem was initiated using Windows File Explorer in Win XP to install WC FPGA1.1. Is this correct?

I had just the opposite experience with HW2.81. My SYS was corrupted by using Window 10 to install WC’s FPGA1.0.bin in DFU mode (DFU 3.45C), then restored using Windows XP.