DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes)

I just installed The Wildcat 3.1 app. (Hardware v2.6, SYS 1.50)

Thank you so much for this, Wildcat!!! :smiley:

It’s fantastic!

I just found one issue.

The frequency of the internal signal generator is 4 times higher than indicated.

The internal frequency counter and the FFT display the real frequency. e.g. with the signal gen set at 1 kHz the app displays 4 kHz.

I confirmed with another frequency counter and it also shows 4 kHz when the signal gen is set to 1kHz.

Any idea?

Sorry if this has been addressed before.



Are you using the modified SYS that was designed for the community app? That will cause that effect with the WIldcat APP which is designed to use the standard stock SYS.

So… is there -any- firmware out there that works with HW 2.72? Or am I now stuck with an albatross? :cry:

Thanks for your answer!

Good question :oops:

On my display it says SYS 1.50 SmTech 1.6

Could you please target me to the correct SYS?

Edit: just found everything on page 1 of this thread.

Now that’s embarrassing :smiley:

Ok found everything on the DSO wiki :smiley:

Works like a charm now!

HW 2.72 with 8M?

I have HW 2.6

Having a new Quad with 2.72/8M I am wondering what to do about the community software.

Just a thought - would there be any way to reformat the 8M as a 2M and reduce the cluster size so it would not have the software issues? Or, could a small partition be copied onto the device with something like Partition Master?


I don’t think one would be able to make the 8M device behave like a 2M one. It’s not about partitioning, it’s more about the fundamental hardware block size used when the device erases and writes new data. That means the routines that do writing have larger buffers.

I think the most fruitful approach is to use the SYS 1.60 which supports the 8M device and then adjust the apps to be compatible with this. The calls made to the SYS are pretty much the same with the main differences being in the memory allocation, so it should be relatively straightforward. This is also evidenced by the gabonator app which largely works with 1.6 except for storing data. I did start to look a this as a family member has a 8M model whereas mine is 2M, but have not had much time to pursue this further recently.

The 2.72 / 8M issues seem to be fixed, please see the last upload in this thread: <LINK_TEXT text=“http://www.seeedstudio.com/forum/viewto … 187#p19187”>http://www.seeedstudio.com/forum/viewtopic.php?f=26&t=5128&p=19187#p19187</LINK_TEXT>

New update:

Tentative support for 8MB devices. Integrated bobtidey’s mods. Note that this has not been tested

on other than 2MB units at this time.

Added persistence and map modes, BMP load, and 30db extra gain to all FFT functions.

Updated spectrograph and XY modes + many minor improvements and bug fixes. See

changelog in README.TXT for complete list and how to use these. Program still fits

within 2 slots.

Persistence mode of RF eye pattern

in RAW data mode

Persistence mode of a video signal

in NORMAL data mode

30db additional FFT gain with

auto scaling

Voice print of person speaking

MAP mode of video frame

XY display of stationary pattern

in persistence mode

I tried this latest on my 8MB 2.72 with 1.6. It seems to work though I don’t understand how to operate it. After bringing up the meters on the right, are you able to change what is displayed as in the original app?

Also, I assumed, maybe incorrectly, that app1, app2, app3 refers to the slot residency? I tried that and it looks like they boot in the correct slot but I get a blank screen.

Anyway, I applaud what everyone has coded and love the little device. I wanted something for on my desk as sometimes the DDS freq generators and other equipment I have won’t start and I can’t figure out what is going on without a scope. After purchasing this little unit, I also bought a larger inexpensive DSO as well so it was ‘scope week’ at my house. Been using an oldy but goody 300mhz tek 2465 for years which had a ton of functions with cursors, etc, but no storage.

So please keep up the good work. I would love to be able to boot wildcat from 2 or 3 keeping the original in 1. I have gabonator’s code in 4 which I like as well.


after installing the wildcat version and reinstalling the original factory app, I can no longer install the wildcat. It installs ok with .rdy message, but boots to a blank screen.

Any ideas?

App1, app2, etc do refer to slot residency. However, most apps, including mine and the originals occupy 2 slots.

So if, for example you have the original in slot 1, adding another version in slot 2 wipes off the last half of the one

installed in slot 1. Likewise, installing in slot 3 wipes off whatever program is in slot 4. The gabonator app installed

in slot 4 I believe adds the rest of the code in some undocumented part of the ROM. This needs to be kept in mind

when adding programs so they don’t overlap and destroy each other and kind of limits it to only 2 programs unless

2 of them can fit in only 1 slot each.

There has been some effort to rewrite the code to all these apps so only the first part of each of the programs fit in 1 slot

only, the rest to the aforementioned undocumented area. However this was only compatible with the older 2M devices.

The meters in my version can be changed like the original app, but the controls to do so may be different. While the

first “page” showing displays for both ChA and ChB can’t be changed, the 4 remaining pages, each set up for one

of the channels can be changed to any relevant meter with source from any channel, but only until the page is changed.

Change pages with long press left toggle center. To change the meter items or source, long press right toggle center,

this will change the focus (blinking) to the meters. Use the right toggle to change between meters and the left toggle to

change the meter item itself (Vdc, Frq, etc). With a meter highlighted (blinking) short press button 4 to cycle between the

different channels as the source (Item will change to the channel’s color). Note that voltage meters are not available for the

digital channels. Keep in mind what while you can cycle between small, large and no meters without changing the selected

items, changing pages will return the pages to their default settings.

Custom meter settings can be saved by saving the entire configuration to a different config file, but only 1 page can be

saved (the one showing), since changing between pages restores defaults. When recalled, the custom settings will be

restored. My version allows 9 additional config files to be saved/restored. Hold button 3 down to access config save,

then if desired, change file number with left toggle. Config #0 is the boot up file. In order for all this to work, 9 extra

config files MUST already be on the device’s flash drive as the program will only save them if a file already exists.

This was done for compatibility with older devices which had systems that corrupted files. Copying these files and

putting them early in the file allocation table prevented the corruption. The 8Mb devices I believe fixed the corruption

problem, as did the Alterbios add-on for the 2Mb devices. Simply copy 9 instances of the xxxxx.WPT file with a

Windows machine, then rename them CONF001.CFG to CONF009.CFG.

For further info on operation, check out the changelogs and other info in the readme.txt enclosed in the archive.

A brief description on how to use the different functions is included. Holding down button 1 on the device will show

a chart of button functions. I’ve started to write a comprehensive “user’s manual” for my version. When I can find the

time to finish it, I will post it, along with some likely further updates (finishing up an additional log amplitude screen

option for the FFT function). The program is getting a bit complex, hopefully this will be of help.

wildcat, thanks, all that above really helps.

Why do you think it won’t install? If I use app1 and have nothing in #2, I still get a blank screen when I load your program. It worked the first time. It is almost like it is stuck in standby mode???

Now that I know how to change the meter pages I would like to install it in slot 1.


What happens when you boot up? Do you see the startup screen with hardware,

FPGA, system version, program version and so on? Or does it just go directly to a blank screen?

If it shows the startup screen, there will be a message showing whether the

program loaded a config file: if it found a file it will read “Reload parameter from disk”.

If no file is found you will see “Parameters not found” or something like that.

If a config file is loaded and it freezes up after that, you should delete any

XXXXX.WPT on the flash drive; you will need to boot up to a running program

and connect to a computer via USB to do this. It’s possible a corrupt config

file may be causing this. Earlier versions used a WPT extension for their

config files, but I think the later (with 8Mb devices) versions use a different extension.

If it goes directly to a blank screen something likely got corrupted.

Can you load any other programs into slot 1 (or any other) and have them work?

I take it you get the .rdy file after copying the hex file when you instal the program

with the bootloader? If other programs load/run OK and there is no WPT config file

on the device maybe the HEX file got corrupted somehow?

I deleted the .wpt file, reloaded, and off it went. Thanks again.

How do you save screenshots and buffer with wildcat. I have 3.2 installed and accourding to the readme it appears it has the capability but my searches have turned up nothing.

The same way you do with the original apps. Didn’t write specific info as most were familiar with them already.

Select file menu: shift right toggle to the right until file menu appears in the notification area. You can just hold

the right toggle to the right until the selection stops the end with the file menu. The default from boot up will be

to “LOAD FILE000.CFG” This is to make it easy to select different config files. Button 4 will cycle between LOAD,

FILE000, and .CFG. With LOAD blinking, use left toggle to change it to SAVE. Select different files with

FILExxx. Cycle through the file types with left toggle, then save by center pressing left toggle.

CFG are configuration files.

BMP are screenshots of anything displayed on the screen, including the FFT, MAP and spectrograph,

etc. (you can use the load function to view these on the device or view them via USB on a computer),

DAT files save the screen trace buffer from all 4 channels (you view these by first loading them back into the

device with the LOAD function. This then makes them available to recall and display from channel D via

“REC_A, REC_B etc…” selecting the saved ch A, B, C, or D trace).

BUF files, unlike the DAT files which save only what is shown on screen, save the entire buffer. After loading

these back up, the device will be in PAUSE with the saved trace displaying. You can use the XPOS control to scroll

through the buffer, if it was saved with the full buffer. Pressing RUN will return the device to it’s previous state.

CSV files are a comma delimited readout of the entire buffer for all 4 channels, used to export the waveform

data to external programs that can then reconstruct the waveforms. These cannot be loaded back into the device.

Note that saving more than a few files on the early (2MB) devices will quickly corrupt them unless the Alterbios

add-on is installed. This is a problem with the early operating systems used on these devices and not the program.

Alterbios patches the OS so the files are saved correctly.

Hi Wildcat,

Awesome firmware! Unfortunately with version 3.2 it seems to limit voltage to 30V. Is this a bug or by design? I had version 2 installed and I don’t think it had that limitation, though I only had it installed briefly so I might not have noticed. I noticed it first after calibrating. My calibration source was 53V but the scope showed 30V as Vmax and using the markings on screen. I slid the pot down on my volt source and as it went below 30V the screen updated to show under 30V. I also looked at a sine wave peaking over 30V and it clips flat at 30V.

If it’s a bug and I downgrade to v3 to try to fix it, will it lose my calibration settings?

I’m running hardware v2.7 (2mb ram), sys 1.52, FPGA 2.61.