COM Port is non-existent after writing firmware XIAO nrf52840 Sense

Hey all,

I recently wrote some firmware to my XIAO nrf52840 Sense board, and in doing so, I’m unable to access the new COM port. I’ve tried a computer restart, an arduino IDE uninstall, and writing the blink sketch with no luck in making it show up. I’ve also checked the device manager in Windows with no indication it’s plugged in.

I can see the COM port just fine when in DFU mode, but after writing firmware it’s unavailable. I’ve determined it’s not a computer or cable issue since one of my other sense boards works as intended on both of my computers.

Would flashing the bootloader with a JLink be a solution or is there something else I’m missing?

Thanks in advance!

Hi there,
So if it shows up in BL mode , What’s the issue?
Connect to the IDE on that New Com port and send it a Known Good Code or even better Drag a uf2 flash file to it. (that already has the bootloader and softdevice in it.)
Look at the Uf2 thread and pick any of the examples. That will bring it back from tha bad code you sent it earlier. here’s the RGB blink one. (basic) unzip and Drag & Drop. :+1:

GL :slight_smile: PJ

FYI, It’s NOT Bricked if it will enter BL mode. :v: :smiley:

Thanks for the response. I was able to write some known working firmware, but the COM port doesn’t show up afterwards still. I was able to borrow a J-Link to reflash the bootloader, but I’m having trouble connecting to the board. One of my computers doesn’t have any of the drivers for the J-Link, and the second one fails when connecting to the board.

Any ideas?

Hi there,
Yea, Go get Nrf_connect for desktop and install it, MUST have for Nrf52series, install the programmer.
B4 anything you load up Jlink commander and connect to the MCU, check out the Threads I have on here doing that with screen shots.

B4 you go to all that , Unzip the RGB blink.uf2 file and drag it to the Xiao drive. That has know good everything on it. Un plug it , and plug it back in , do you get a new device sound? does it show?
Start there, b4 you go Head first.
GL :slight_smile: PJ

You’re correct. I tried dropping a uf2 file to it last week which didn’t work, but after a couple attempts, I was able to get the COM port to show back up.

Thanks for your help!

1 Like