Lipo Rider PRO overVoltage

Ardiuno Compatible shields

Moderators: lily.li, violet

Post Reply
luis
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Fri May 11, 2018 10:16 pm

Lipo Rider PRO overVoltage

Post by luis » Fri Jan 04, 2019 12:47 am

Hi, I'm working on a project that was initially built by someone else and to be powered by a 850mAh lipo battery and a lipoRiderPro with a 8w solar cell.

The solar panels were not purchased on SeedStudio, and I believe that the voltage coming from the solar panel has damaged the boards. My system is not able to charge the battery every day and I have to reset the whole system sometimes by charging the battery using an external charger and then connect it again to the Lipo Rider.

Sometimes when the system stop charging, I press the volume button the leds just blink and I do not get the actual battery level, the whole system is very unstable, with random resets and malfunctions of the RTC I included.

I've measured the voltage on our maximum sun brightness and exceed 7v for more than 10 secs, could that damage the board and burnt the C1, C2 and maybe C6 capacitors?

On open sky at 13.30 I've measured 7.25V coming from the Panel, could that be the origin of my problems?
Attachments
image.png
image.png (3.59 MiB) Viewed 838 times

User avatar
bestlux
Kindergarten
Kindergarten
Posts: 85
Joined: Wed Jan 30, 2019 11:51 am

Re: Lipo Rider PRO overVoltage

Post by bestlux » Thu Jan 31, 2019 11:24 am

Hello,

I'm sorry to tell you that it looks like there is no Triode on this board so it can not protect itself from high voltage.

It looks like that your smoothing capacitors are burned, so the voltage of this board become instability. You can try to switch them, but I can not say there are no problems with other components on your board for sure.

Remember to install a DC-DC buck converter between the power source and your board without protection circuit first.

Good luck!

Post Reply