BBG Wireless Bluetooth script not working?

Moderators: lily.li, violet, salmanfarisvp, seth.welday

Post Reply
hiron
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Tue May 29, 2018 12:50 pm

BBG Wireless Bluetooth script not working?

Post by hiron » Wed Dec 19, 2018 11:10 am

Hello,

I am using BeagleBone Green Wireless and would like to use Bluetooth capability. But when using the latest Debian image (i.e. Debian 9.5 2018-10-07 4GB SD IoT found https://debian.beagleboard.org/images/b ... 4gb.img.xz ) and following the Wiki page below...

http://wiki.seeedstudio.com/BeagleBone_ ... oth-device

kernel dmesg appears OK but Bluetooth initialize script fails.

debian@beaglebone:~$ bb-wl18xx-bluetooth
Wanted to write 4 bytes, could only write 0. Stop
Can't initialize device: Success
debian@beaglebone:~$

When I open /dev/ttyS3 direct with "cu", any character input will close the connection.

=================================================

When I tried the same procedure in the old (Debian 8.4 beaglebone 4.4.9-ti-r25 kernel) it worked as the Wiki instruction explains...

( note: Debian 8.x requires sudo for the proper operation)

debian@beaglebone:~$ sudo bb-wl18xx-bluetooth
Found a Texas Instruments' chip!
Firmware file : /lib/firmware/ti-connectivity/TIInit_11.8.32.bts
Loaded BTS script version 1
texas: changing baud rate to 3000000, flow control to 1
Device setup complete
debian@beaglebone:~$

=================================================

So does anybody have solution for Debian 9.x ?

Thanks,
Hiroyuki NAKAYAMA

bill.yu
Junior-6
Junior-6
Posts: 653
Joined: Mon Apr 02, 2018 11:05 am

Re: BBG Wireless Bluetooth script not working?

Post by bill.yu » Sat Feb 02, 2019 3:07 pm

Hi there,

please try below commands. thanks.

udebian@beaglebone:~$ uname -a
Linux beaglebone 4.14.71-ti-r80 #1 SMP PREEMPT Fri Oct 5 23:50:11 UTC 2018 armv7l GNU/Linux
debian@beaglebone:~$ bluetoothctl --agent
[NEW] Controller A4:D5:78:6D:6F:E0 beaglebone [default]
Agent registered
[bluetooth]# scan on
Discovery started
[CHG] Controller A4:D5:78:6D:6F:E0 Discovering: yes
[NEW] Device C0:72:BC:0A:E6:1E HB7910703602
[NEW] Device E8:19:C4:6B:03:5C YONGNUO LED
[NEW] Device C0:F6:1E:02:0A:1E HB7690138998
[NEW] Device CC:51:96:72:10:EB mobike
[NEW] Device F7:56:B8:CF:BA:3D mobike
[NEW] Device CB:98:4C:07:38:4F mobike
[NEW] Device C0:FA:E3:00:F0:0A HB2800058362
[NEW] Device C0:DF:71:08:E6:1E HB7910553439
[NEW] Device 3C:A3:08:06:00:03 3C-A3-08-06-00-03
[NEW] Device 59:29:36:75:62:61 NokeLock
[NEW] Device E0:06:E6:BB:97:53 X1-THINK
[NEW] Device 7B:77:21:7C:62:61 NokeLock
[CHG] Device E8:19:C4:6B:03:5C RSSI: -100
[CHG] Device E8:19:C4:6B:03:5C RSSI: -89
[CHG] Device E8:19:C4:6B:03:5C RSSI: -81
[CHG] Device E8:19:C4:6B:03:5C RSSI: -93
[CHG] Device E8:19:C4:6B:03:5C RSSI: -81
[CHG] Device 80:35:C1:25:72:38 RSSI: -59
[CHG] Device E0:06:E6:BB:97:53 RSSI: -88
[CHG] Device E0:06:E6:BB:97:53 RSSI: -78
[CHG] Device E8:19:C4:6B:03:5C RSSI: -90
[NEW] Device C8:70:22:3E:1C:F0 mobike

hiron
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Tue May 29, 2018 12:50 pm

Re: BBG Wireless Bluetooth script not working?

Post by hiron » Wed Feb 06, 2019 2:33 pm

confirmed. In Debian 9.x there's no need to run "bb-wl18xx-bluetooth" script but just run "bluetoothctl" Blue-Z utility.

following is my testing result.

Code: Select all

debian@beaglebone:~$ uname -a
Linux beaglebone 4.14.79-ti-r84 #1 SMP PREEMPT Tue Nov 13 20:11:18 UTC 2018 armv7l GNU/Linux
debian@beaglebone:~$ bluetoothctl
[NEW] Controller F0:45:DA:33:72:C8 beaglebone [default]
[bluetooth]# agent on
Agent registered
[bluetooth]# scan on
Discovery started
[CHG] Controller F0:45:DA:33:72:C8 Discovering: yes
[NEW] Device 44:85:00:C5:9C:79 TP460S-WIN10
[NEW] Device 38:89:2C:40:EA:07 MyiPhoneX
[bluetooth]# exit
Agent unregistered
[DEL] Controller F0:45:DA:33:72:C8 beaglebone [default]
debian@beaglebone:~$
Thanks,
Hiroyuki NAKAYAMA

Post Reply