Respeaker Raspian Release compatability ?

info about ReSpeaker series products

Moderators: lily.li, violet, seth.welday

Post Reply
jim565
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Sat Dec 01, 2018 11:24 pm

Respeaker Raspian Release compatability ?

Post by jim565 » Sun Dec 02, 2018 7:42 am

Hi,

I notice on the respeaker wiki page it states "Make sure that you are running the lastest Raspbian Operating System(debian 9) on your Pi. (updated at 2018.6.27)" -

This is no longer the latest release which I believe is dated 2018.11.13.

I suspect that this statement : "While the upstream wm8960 codec is not currently supported by current Pi kernel builds, upstream wm8960 has some bugs, we had fixed it. We must build it manually" - means that the git package is no longer valid (with the latest raspian release) in terms of getting the 2 mic respeaker hat to work ????

Please let us know ??

Thanks
Jim

bill.yu
Junior-7
Junior-7
Posts: 732
Joined: Mon Apr 02, 2018 11:05 am

Re: Respeaker Raspian Release compatability ?

Post by bill.yu » Mon Dec 03, 2018 3:51 pm

Hi Jim,

We generate the wiki around July and we use the 2018.6.27 image for the test. We are not updating the wiki yet.
We tested it with 2018.11.13 image and it also works. Here is my output.
We suspect that the driver is not installed correctly. Please uninstall the driver and install it again. thanks.

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux
pi@raspberrypi:~ $ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: seeed2micvoicec [seeed-2mic-voicecard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
pi@raspberrypi:~ $

Post Reply