firefox-esr not working, librosa linker errors

info about ReSpeaker series products

Moderators: lily.li, violet, seth.welday

Post Reply
boran.aidan
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Sat Oct 06, 2018 8:14 pm

firefox-esr not working, librosa linker errors

Post by boran.aidan » Sat Oct 06, 2018 8:25 pm

Hi all,

Just want check with others if they have similar problems to me.

My config - respeaker core v2. 64Gb sdcard running the standard lxqt image.

After installation, I did:
- sudo apt-get update
- sudo apt-get upgrade
- used fdisk to expand the sdcard to full size.

At this stage, everything seems to work ok (audacity works, vnc works, alsamixer, arecord etc)


However: the following bits are not working
- firefox -> gives a segmentation fault
- I also tried to install 'librosa' (needs a manual build of llvm 6.0) - seems to install ok but I get linker errors when trying to run it
- chromium installs but crashes on start

Have other been able to run firefox or any browser....

dave.rogers
Pre-kindergarten
Pre-kindergarten
Posts: 8
Joined: Tue Jun 19, 2018 6:59 am

Re: firefox-esr not working, librosa linker errors

Post by dave.rogers » Tue Oct 16, 2018 1:03 am

I also have this same problem.

You can reproduce it by starting with the lxqt OS image, and executing:

$ sudo apt-get update
$ sudo apt-get upgrade

After the upgrade, Firefox-esr no longer works. I notice that a new version of Firefox-esr is installed as part of the upgrade. .

This does not matter for our IoT/flash environment, but it sure messes up our development environment! Can we get a new OS image that fixes this? Not having a local browser is a really hassle - and some steps for authentication require it!

Thanks, David Rogers

willibald.meyer
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Sun Dec 09, 2018 8:57 pm

Re: firefox-esr not working, librosa linker errors

Post by willibald.meyer » Sun Dec 09, 2018 9:02 pm

use 'sudo apt-mark hold firefox-esr' before udate.

Regards

Post Reply