Invalid GPIO pin specified

info about ReSpeaker series products

Moderators: lily.li, violet, seth.welday

seeedstudio28
Pre-kindergarten
Pre-kindergarten
Posts: 10
Joined: Wed Nov 16, 2011 3:04 am

Re: Invalid GPIO pin specified

Post by seeedstudio28 » Sun Aug 05, 2018 10:20 am

Looks like a new image was posted (20180801) which is nice.

Sadly it doesn't boot. iot-sd and iot-flasher... uboot can't finish booting.
The name of the dtb file in uEnv.txt in the /boot directory is wrong so when uboot trys to load it its unable to and then the boot hangs.
Once the proper path is set manually (via the tx/rx port using a uart adapter to get the uboot console) then booting proceeds correctly.
After that (in my case) the flasher script takes over and flashes the system (with the still incorrect uEnv.txt file).
You can then fix the dtb setting on the mmc and all future boots proceed correctly.

So it looks like the image is still sadly a little messed up.

LED lights though work properly though with this build. So that is a plus :-)

chris.

seth.welday
Staff
Staff
Posts: 35
Joined: Mon Mar 26, 2018 10:04 am

Re: Invalid GPIO pin specified

Post by seth.welday » Mon Aug 06, 2018 3:18 pm

Hi Chris,

I am having the team look into this now. I am hoping we can reply by the end of work tomorrow.

Also, your name really confused me. I thought you were a Seeed employee at first, hah!
---------------
Seth Welday
Human Being @ Seeed

seeedstudio28
Pre-kindergarten
Pre-kindergarten
Posts: 10
Joined: Wed Nov 16, 2011 3:04 am

Re: Invalid GPIO pin specified

Post by seeedstudio28 » Tue Aug 07, 2018 8:14 am

Thanks for looking into this.

And ya. I can't change my forum name, and it somehow carried across from my purchase account. Not sure.

chris.

bill.yu
Junior-7
Junior-7
Posts: 735
Joined: Mon Apr 02, 2018 11:05 am

Re: Invalid GPIO pin specified

Post by bill.yu » Tue Aug 07, 2018 8:43 pm

Hi Chris

Please try to download it again and it shall work now. thanks.

Bill

Post Reply