Problem connecting to Private APN

Simplify IoT Development.

Moderators: lily.li, violet, seth.welday

Post Reply
spmaurer
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Wed Jul 18, 2018 6:17 am

Problem connecting to Private APN

Post by spmaurer » Tue Jul 31, 2018 6:52 am

I have purchased a Wio LTE Cat M1/NB-IoT Tracker and finally been able to connect to it, but I need to change the APN it connects to and provide a username and password. I have tried all AT commands that look like it should work but I suspect it needs a correct sequence of commands. I now the SIM card works fine because I have tested it in another Cat M1 device.

Can you please provide the sequence of AT commands to change the APN and add a username and password to connect to the Private APN?

bill.yu
Junior-7
Junior-7
Posts: 733
Joined: Mon Apr 02, 2018 11:05 am

Re: Problem connecting to Private APN

Post by bill.yu » Tue Jul 31, 2018 3:12 pm

Hi, please refer to below. fore more info, please refer to 13.1.3    Parameter definition of https://www.u-blox.com/sites/default/fi ... 787%29.pdf

An example for the usage of <APN> is:
AT+CGDCONT=1,"IP","CHAP:internet.t-d1.de"

thanks
Bill

spmaurer
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Wed Jul 18, 2018 6:17 am

Re: Problem connecting to Private APN

Post by spmaurer » Wed Aug 01, 2018 7:17 am

Hello,
I have figured out what to do to make it work. The AT Command manual has some errors in it.

The example in the AT Command Manual doesn't work.
AT+CGDCONT=1,"IP","PAP:telstra.corp"
+CME ERROR: operation not supported

If I change it to the following, it works.
AT+CGDCONT=1,"IP","telstra.corp"
OK

Changing the APN now works, but entering the username and password is now the problem.
I have tried the following AT command but doesn't register to the new APN.
AT+UAUTHREQ=1,1,"user","pass"

If I swap the username and password around, it works.
AT+UAUTHREQ=1,1,"pass","user"

Below is the list of commands I used to get it to register to my Private APN:

AT+CFUN=4
AT+CGDCONT=1,"IP","APN"
AT+UAUTHREQ=1,1,"password","username"
AT+CFUN=1

bill.yu
Junior-7
Junior-7
Posts: 733
Joined: Mon Apr 02, 2018 11:05 am

Re: Problem connecting to Private APN

Post by bill.yu » Wed Aug 01, 2018 9:26 am

Hi, thanks for keeping us posted.

Bill

Post Reply