#idea Received Wio yesterday - now on Node-red

Simplify IoT Development.

Moderators: lily.li, violet, seth.welday

Post Reply
philip.mallon
Pre-kindergarten
Pre-kindergarten
Posts: 34
Joined: Fri Oct 31, 2014 12:32 pm
Contact:

#idea Received Wio yesterday - now on Node-red

Post by philip.mallon » Wed Apr 13, 2016 7:14 am

Received my Wios yesterday and already linked and working with two grove modules. I have mounted everything on Lego and it is a convenient layout. I am using the Android app but was disappointed when software was not downloaded into the Wio after connecting a grove pushbutton and LED and configuring on the Android app. Started with buzzer but changed to LEDs after complaints! I then used the App listing for details of the REST commands and configuration and this worked. Put these into Node-red 'hpttp request nodes' and it worked for the push button using GET but the POST on the LED did not work. Tried Chrome 'Rest Easy' app on my Windows PC and both GET and POST examples worked there - alternatively could have used POSTMAN. As a work around I use the Node-red 'exec' node with Curl commands for POST and this worked for all examples including 'sleep'. Now I have my first node-red flow with Wio. Good start but I have to poll the push button to see its status. I can overcome this by using websockets and events but I have to learn that technique first. Overall wio at the moment is not for beginners and has a considerable way to go but it is a good start at a reasonable price and should blend in well with the Grove eco system. Hope a month of so year beginners are using it.

yexiaobo
Pre-kindergarten
Pre-kindergarten
Posts: 46
Joined: Tue Dec 11, 2012 10:53 am

Re: #idea Received Wio yesterday - now on Node-red

Post by yexiaobo » Wed Apr 13, 2016 3:48 pm

It's awesome!!!

I like this idea.

Could you share it on recipe (http://www.seeedstudio.com/recipe/)?

Post Reply