BenF 3.x FW on new LCD driver devices [flick. screen solved]

Moderators: lily.li, violet, jeremy882, crail.lyu969

stigern
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Mon Sep 01, 2014 7:36 pm

Re: BenF 3.x FW on new LCD driver devices [flick. screen sol

Post by stigern » Mon Sep 01, 2014 7:39 pm

Hi

I just bought me a DSO Nano V3.

I'm a previous owner of a v1 but since the USB connector fell off I thought I get a new one :)

So to my problem, as far as I understand I need this firmware for my device. So I have it downloaded.

Some information:

Version shows V. 4.28.
Serial: E3CCCAD8
Licence: 340E242A

Device Firmware upgrade: V3.29D

But a problem arises when I put it in firmware mode by pressing arrow down and turning it on. The virtual disk appears only a few seconds, then it's gone. Only shows up as a Removable Disk F: Tried several cables and several computers from Windows 7 to Windows 8. Same happens on every computer, so I'm kind of ruling out my computers.


Any ideas?

EDIT:!

Just for the heck of it, tried it on the second computer again, and to my suprise the virtual disk stayed.

So I got it upgraded. Do I understand it correctly if I only need the one hex file? BENF_P2.hex

ivashi
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Thu Sep 25, 2014 12:20 pm

Re: BenF 3.x FW on new LCD driver devices [flick. screen sol

Post by ivashi » Thu Sep 25, 2014 12:25 pm

Thanks for patched BenF. I just want to ask, why my 2gb SD card now detected as 32gb (official FW displayed it properly). Is this a bug or feature? Thanks. :)

tommcg
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Sat Nov 22, 2014 12:47 am

rimidalv007 patch V2

Post by tommcg » Sat Nov 22, 2014 12:51 am

I also want to express my thanks to rimidalv007 for taking the time to make the BenF firmware work on latest hardware and sharing it here. THANK YOU!!!

I recommend updating the wiki to also point at this latest patched version.

lavoie.michel
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Tue Dec 02, 2014 8:56 am

Re: BenF 3.x FW on new LCD driver devices [flick. screen sol

Post by lavoie.michel » Tue Dec 02, 2014 9:01 am

rimidalv007 wrote:I fixed bugs detected in my first version of patch.

Detected and fixed bugs:

1. Bug in export to SD card - fixed
2. Bug in setting of grid intensity option - fixed

Patched firmware is in attachment.

Enjoy!
I too wanted to thank you for your work, you have given meaning to my up-to-now useless Nano!

The source would be awesome, but still thanks for your work!

phil15
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Wed Dec 31, 2014 7:46 am

Re: BenF 3.x FW on new LCD driver devices [flick. screen sol

Post by phil15 » Wed Dec 31, 2014 7:51 am

Thanks for your efforts in improving the BenF Firmware.

I've just found this forum after getting a Nano V3 fro Christmas.

I see it's been asked before but I'll ask again as there was no answer, will it ever be possible to save data to the internal memory of the V3 (without SD card)

I've updated it to 3.64 patch V2.

Thanks,
Phil

jerpub
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Thu Jan 08, 2015 11:42 pm

Re: BenF 3.x FW on new LCD driver devices [flick. screen sol

Post by jerpub » Thu Jan 08, 2015 11:48 pm

Hi there,

I would need help from the experts please.

I have bought just few days ago a DSO201 nano v1, serial: E3D0CEC7, Licence: 171B9CF7, DFU: 3.29D

I tried several times to upgrade the firmware with the file BenF_3.64APP_3.53LIB_patched_v2.zip but i always get an .err file after dropping the .hex on the DFU...

Can anybody help ? Is there another file I should try ?

Thank you very much for your help !!

Jerome

limon93studio
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Fri May 22, 2015 11:20 pm

Re: BenF 3.x FW on new LCD driver devices [flick. screen sol

Post by limon93studio » Fri May 22, 2015 11:34 pm

I fixed microsd slot problem, via hardware, applying a custom card slot over unpopulated pcb.
Images e reference in english on my site, i cannot post links in my first 24 hours of account life sorry.


https: // limon93.wordpress. com/2015 /05/22/ dso-nano-v3-micro-sd- card-diy-upgrade

Remove six spaces from the url to open it, tomorrow i'll fix.
No SPAM.
No ADS exept wordpress ones.

registration
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Sat Jun 06, 2015 12:12 pm

Re: BenF 3.x FW on new LCD driver devices [flick. screen sol

Post by registration » Sat Jun 06, 2015 12:22 pm

Hi, new DSO 201 owner here trying to install the BenF firmware, unsuccessfully so far. It came with firmware 4.28.

In DFU mode, the screen reports:

NiN
digital storage oscilloscope

Serial: DDDAB8BB License: 41BE9A7F
Device Firmware Upgrade: V3.29D
Please copy Hex or Bin file to
the DFU virtual USB disk.

I copy the BENF_P2.hex file from BenF_3.64APP_3.53LIB_patched_v2.zip to the device and I see it deactivate and come back, with now BENF_P2.RDY on it. Power cycle the device, and I'm back to the 4.28 version. It seems like the device thinks it has installed the new firmware, but not actually.

I have tried various other firmware versions. Every now and then it works correctly. At the moment I'm on firmware v4.30, but I have not yet managed to get the BenF version to install. Any ideas? Google led me here, and has found plenty of discussion of firmware install failures, but none quite like this.

In messing around with the device, I found a hardware information screen. Power up with the [-] and [M] buttons held down and I get a screen that looks like:

NiN
digital storage oscilloscope

Hardware: Version 1.7B
MCU Type: STM32F103VB
LCM Ctrl: ILI_9341
USB Disk: Ext MSD Card

I haven't seen this mentioned anywhere else, though it seems unlikely that I'd be the first to stumble upon it.

treii28
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Sat Jul 18, 2015 12:17 pm

Re: BenF 3.x FW on new LCD driver devices [flick. screen sol

Post by treii28 » Sat Jul 18, 2015 12:27 pm

OK I have a DFu V3.29d Hardware v1.7B, MCUtype STM32F103VB, LCM Ctrl: ILI_9341 and seem to have every headache described in this thread.
I tried upgrading with the latest dfuse demo, but no devices show up. I tried installing from the 3.0.0 version, same problem. I tried doing drag-n-drop but the drive either disapeers or the attempt times out. I tried installing the driver over the defaulted on in windows (driver that came with the 3.0.0 version) but it always falls back to the windows driver.
I tried throwing dfu-util on two different linux based machines - I tried everything under the sun to get it to see the dfu devices with no luck.
I eventually found that on linux I could get the /dev/sd? to mount from root. I tried copying the two files in together, dismounted the partition, remounted and saw one reading RDY, the other reading ERR. I tried copying them one at a time - dismount/remount and saw RDY on each that way one at a time. I powered off and back on and had the white flashing screen.

I came to this thread and have tried again with the original two files twice (together and separate) and the patched version twice. I have tried grabbing a LIB301_APP311_2 suggested by one user, still white flashing. I tried grabbing DSO Nano 2.6 official firmware - still white flashing.

At this point I don't care if I end up on some old version - can anyone tell me how to un-brick this thing please?

The dfu mode still comes up fine and the info mode still come up fine, and I can see the logo briefly before the flashing thing. Any help would be greatly appreciated.

treii28
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Sat Jul 18, 2015 12:17 pm

Re: BenF 3.x FW on new LCD driver devices [flick. screen sol

Post by treii28 » Sat Jul 18, 2015 9:19 pm

OK, I finally got it. What I did that helped was that instead of keeping 'My Computer' open in windows explorer, I opened any other folder and set the left side to show folders and made sure computer was expanded there instead. (I suspected the regular behavior windows explorer would try to 'read' the DFU device which was confusing the thing and triggering the disconnect/reconnect behavior)

At that point I could see the DFU device connect without it immediately vanishing, copied the P2 over and it took in one shot.

SW

Post Reply