Page 1 of 1

xadow mainboard usb unknown device

Posted: Tue Oct 06, 2015 6:38 pm
by 92421
xadow main board v1.3
windows 7

the mainboard worked 2 months on this pc
now
when i connect the board on usb port
the device manager shows
for 5 seconds : seeeduino xadow com7
and then the device manager refresh the screen
and shows under usb controller : unknown device
no led lights - never

i tried some resets
i change the pc
i reinstall the usb driver

always the same

Re: xadow mainboard usb unknown device

Posted: Wed Oct 07, 2015 3:49 pm
by viswa
Hello,

Please try the following steps:

1. Change your USB cable (There might be some losse connections ?!?)
2. Reinstall Arduino IDE and Xadow Driver (See here)
3.Only connect Xadow main board without any other boards to PC.

Thanks and Warm Regards

Re: xadow mainboard usb unknown device

Posted: Wed Oct 07, 2015 6:15 pm
by 92421
i have done this
a complete new laptop
a new install of arduino software

when i connect the usb cable with mainboard - there is no green/blue light

- a short time (a half second) i see in the device manager
under other devices : seeduino xadow

- the the device manager refresh

- and i see under usb controller : unkown device
and there i can not install a driver
also not manuell

i changed also the cable - same effect

Re: xadow mainboard usb unknown device

Posted: Thu Oct 08, 2015 2:53 pm
by viswa
Hello,

This issue is very similar to the one posted here. Could you please try out this solution ?

Thanks and Warm Regards

Re: xadow mainboard usb unknown device

Posted: Fri Oct 16, 2015 6:06 pm
by 92421
Thanks for help
i had load a incorrect sketch - see bottom
then i had the same problem
- but under win 7 not under linux
in device manager
i saw for a short time the virtual xadow com port
the a refresh
and the message : unknown usb device

the way out
disconnect mainboard from usbport
start arduino
load sketch ledblink or another sketch

--now be fast--
connect mainboard on usbport
click tools
click port
when you fast enough you see : seeduino xadow port (COMx)
click port this port

start upload the sketch
und when message uploading appears press reset button
- then mainboard make a softreset -
now the led must blink

if not
try again an upload
you can do this more the one times

---------------------------------
i have found the killer sketch
i tries serval times - works good

#include <Wire.h>
#include "xadow.h"

void setup()
{
DDRB |= 0x06;
}

void loop()
{
//turn on the buzzer
PORTB |= 0x06;
delay(1000);
//turn off the buzzer
PORTB &= ~(0x06);
delay(1000);

Xadow.pwrDown(1000); // sleep for 1000ms
Xadow.wakeUp();

}
---------------------------------

greetings

Re: xadow mainboard usb unknown device

Posted: Thu Feb 04, 2016 3:19 pm
by hanifnoor0033
the way out
disconnect mainboard from usbport
start arduino
load sketch ledblink or another sketch

Re: xadow mainboard usb unknown device

Posted: Tue Feb 09, 2016 4:23 pm
by kyakruu
i have done this
a complete new laptop
a new install of arduino software

when i connect the usb cable with mainboard - there is no green/blue light

- a short time (a half second) i see in the device manager
under other devices : seeduino xadow