SD Card support

Moderators: lily.li, violet, salmanfarisvp

Post Reply
albatetra
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Fri Dec 05, 2014 4:37 pm

SD Card support

Post by albatetra » Fri Dec 05, 2014 4:40 pm

Hi everybody.
Anybody is experiencing the same issue like me?
Whenever I select the SD card support (SD/SPI switch moved to SD) the board stops to work. It doesn't execute the sketch, even if the uploading process is successful.
This behavior is the same either if SD card is inserted in the slot or not.
Once the switch is set to SPI the code is properly executed.

Any idea what's wrong with it?

Thanks

Albetetra

albatetra
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Fri Dec 05, 2014 4:37 pm

Re: SD Card support

Post by albatetra » Sat Dec 06, 2014 6:15 am

Just to be clear, It seems that the code is finally executed, but the LED on PIN13 is always ON when SD is selected on the board. Why you didn't documented this on the manual? Why the LED on pin 13 is unusable when SD card is selected? I'd appreciate some reply from developers. Thanks

User avatar
loovee
Elementary-3
Elementary-3
Posts: 352
Joined: Fri Nov 02, 2012 9:15 am

Re: SD Card support

Post by loovee » Sun Dec 07, 2014 10:40 am

Hi, I am sorry we didn't make it clear in the wiki, I will update it soon.
when you set the switch to SD, D0~D13(SPI) are not available.

albatetra
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Fri Dec 05, 2014 4:37 pm

Re: SD Card support

Post by albatetra » Tue Dec 09, 2014 6:15 am

Not all D1-D13 are unusable.
it seems to me that only D13, D12, D11 and D10 are not available anymore when SD is enabled.
Can you please confirm it?

User avatar
loovee
Elementary-3
Elementary-3
Posts: 352
Joined: Fri Nov 02, 2012 9:15 am

Re: SD Card support

Post by loovee » Tue Dec 09, 2014 11:44 am

Just made a mistake! :lol:

Yep, when you set to SD, D10-D13(SPI pins) are not available.

Post Reply