Page 2 of 2

Re: Problem with Motor Bridge Cape

Posted: Tue Apr 26, 2016 1:20 am
by alvinmarquez7
qxn.c wrote:
Hi,

Did your BBB boot with the latest system image from BeagleBone forum?
If so, you have to enable the Serial port 2. It was not enabled by default.

To enable serial port 2, add a line with "cape_enable=bone_capemgr.enable_partno=BB-UART2" to /boot/uEnv.txt and reboot your device. Change the port back to dev/ttyO2 in flasher file.

Hope this can solve your problem, Let me know if further detail/explanation would be helpful.


Hello,

Thanks for the reply. I have tried adding it into the uEnv.txt file as you said, but still no luck in using "make flash_firmware". I have added my output errors if they will help you understand my current situation. My Linux info is as follows: Linux beaglebone 3.8.13-bone79 #1 SMP Tue Oct 13 20:44:56 UTC 2015 armv7l GNU/Linux

EDIT (May 4th, 2016): I noticed a typo in enabling the Serial Port 2 with BB_UART2 and have now changed it to BB-UART2, but still can't get it to work. I have tried both formats for 3.8 and 4.1 for enabling the Serial Port 2.

Thanks again in advance,
Alvin

Re: MotorBridgeCape

Posted: Tue Apr 26, 2016 1:24 am
by alvinmarquez7
silver1row wrote:Hello,

I read what was available in this forum. I am getting an issue:

• Error accessing 0x4B: Check your I2C address

I have a MotorBridgeCape with a BBG. I attached two motors and a battery. I used the PuTTY to run my python program I got from the MotorBridge Wiki.

Do I need to update firmware for the MotorBridgeCape or allow the serial bus with python-smbus?

I am new to these issues and I need support.

Seth
silver2row on GitHub

P.S. If someone knows the answer, please try to contact me. Oh and here is a photograph/video. It is my PuTTY Terminal. I cannot access the .zip file once I unzipped it. Please provide support.

https://youtu.be/lqNmfVogOd8

Hello silver1row,

Have you tried the commands mentioned earlier?

I can see you have the folder so try this from the directory shown in the video.

cd Motor\ Bridge\ Cape\ Firmware\ v1.0
make flash_firmware

Let me know if that works for you, as I am currently stuck in using "make flash_firmware" and having it work correctly.

Re: Problem with Motor Bridge Cape

Posted: Tue Apr 26, 2016 10:45 am
by silver1row
Hello,

I found the flasher file in the .zip file I unzipped. Okay, now the tty02 is already listed in that specific location. Where do I go from here?

Seth

Re: Problem with Motor Bridge Cape

Posted: Wed Apr 27, 2016 12:39 am
by alvinmarquez7
silver1row wrote:Hello,

Is the flasher file the .zip file I had to unzip?

Seth
Please try the commands that were mentioned earlier. I believe you have already unzipped the file since I see a directory named Motor Bridge Cape Firmware in the video. Start by running the commands before changing anything else. I just followed those commands mentioned in the earlier post of this thread.

#cd Motor\ Bridge\ Cape\ Firmware\ 1.0
#make flash_firmware

Re: Problem with Motor Bridge Cape

Posted: Wed Apr 27, 2016 12:43 am
by silver1row
Hello...I tried to run the cmd make flash_firmware after unzipping the .zip file. I got an error.

Seth

P.S. This is the error: root@beaglebone:~# make flash_firmware
make: *** No rule to make target 'flash_firmware'. Stop.

Oh and if I run the cmd make flash_firmware in the unzipped .zip file, I get this error:

root@beaglebone:~/Motor Bridge Cape Firmware v1.0# make flash_firmware
make: *** No rule to make target 'flash_firmware'. Stop.

Re: Problem with Motor Bridge Cape

Posted: Sat Apr 30, 2016 4:55 am
by silver1row
Please see the attachments.

Seth

Re: Problem with Motor Bridge Cape

Posted: Thu May 05, 2016 2:44 am
by alvinmarquez7
FIXED, I think.

The problem was on my end with the typos, but anyways, here is what I did to fix it.

I enabled BB-UART2 in my uEnv.txt file using commands given by qxn.c.
nano /boot/uEnv.txt

Add in the following:
#for v4.1.x
cape_enable=bone_capemgr.enable_partno=BB-UART2

#for v3.8.x
cape_enable=capemgr.enable_partno=BB-UART2

Next, check to see if it has been added by using the following:

(THIS IS THE LETTER 'O' NOT THE NUMBER '0' WHICH WAS MY MISTAKE)
ls -l /dev/ttyO*


Output should show:
/dev/ttyO0
/dev/ttyO2

Then just went back to following the main instruction of flashing the firmware by going to the directory and using:
make flash_firmware.


Hope this helps others having the similar problem. Thanks for the help other forum users.



-Alvin

Re: Problem with Motor Bridge Cape

Posted: Thu May 05, 2016 11:47 am
by qxn.c
alvinmarquez7 wrote:FIXED, I think.

The problem was on my end with the typos, but anyways, here is what I did to fix it.

I enabled BB-UART2 in my uEnv.txt file using commands given by qxn.c.
nano /boot/uEnv.txt

Add in the following:
#for v4.1.x
cape_enable=bone_capemgr.enable_partno=BB-UART2

#for v3.8.x
cape_enable=capemgr.enable_partno=BB-UART2

Next, check to see if it has been added by using the following:

(THIS IS THE LETTER 'O' NOT THE NUMBER '0' WHICH WAS MY MISTAKE)
ls -l /dev/ttyO*


Output should show:
/dev/ttyO0
/dev/ttyO2

Then just went back to following the main instruction of flashing the firmware by going to the directory and using:
make flash_firmware.


Hope this helps others having the similar problem. Thanks for the help other forum users.



-Alvin

Alvin,

I found that you have already fixed the issues. The solving steps of the "Motor Bridge Cape firmware issue" is updated to the wiki page http://www.seeedstudio.com/wiki/Motor_Bridge_Cape_v1.0 .

Thank you for your sharing.

Re: Problem with Motor Bridge Cape

Posted: Tue May 17, 2016 8:53 am
by silver1row
Hello,

Thank you. I am going to check this correction soon. Thank you for updating the info. so far.

An "O" and not a zero. Ha! Fooled me too.

Seth

Re: Problem with Motor Bridge Cape

Posted: Tue May 17, 2016 10:16 am
by silver1row
Hello,

I got the motor turning. Things are working so far. Thank you, again.

Seth