LTE CAT1 hat (Europe version)

Applications/questions using Raspberry Pi with Seeed products, please post it here.

Moderators: violet, jessie, yexiaobo

Post Reply
info629
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Tue Aug 14, 2018 1:50 pm

LTE CAT1 hat (Europe version)

Post by info629 » Sun Sep 02, 2018 4:49 am

Hi,
I'm trying to install your LTE CAT1 hat (Europe version), but without success so far. I used the install-procedure as mentioned in the Wiki. Everything went OK, but the response is different, see attached picture. Questions:
- Why is the modem not waking up?
- Do you have any documentation on the library used to control the modem?
Regards,
Felix

Image
Attachments
screenshot.png
screenshot.png (192.2 KiB) Viewed 529 times
Regards,
Felix

bill.yu
Elementary-2
Elementary-2
Posts: 296
Joined: Mon Apr 02, 2018 11:05 am

Re: LTE CAT1 hat (Europe version)

Post by bill.yu » Tue Sep 04, 2018 6:00 pm

Hi Felix

Do you go through below 4 steps? I went through the process again. I get the response from board as below. Maybe you can connect the module to windows pc to test the AT command separately to see if it works. Here is the instructions. http://wiki.seeedstudio.com/LTE_Cat_1_Pi_HAT/#faq. thanks.
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Software¶
Step 1. Use dtoverlay=pi3-disable-bt to enable Raspberry Pi3 UART0.

sudo nano /boot/config.txt
Then add dtoverlay=pi3-disable-bt to bottom of the config.txt

Step 2. Disable the system serivce to use the UART0.

sudo systemctl disable hciuart
Note

Pi3-disable-bt disables the Bluetooth device and restores UART0/ttyAMA0 to GPIOs 14 and 15. It is also necessary to disable the system service that initialises the modem so it doesn't use the UART: sudo systemctl disable hciuart.

Step 3. Delete the console=serial0,115200 in cmdline.txt.

sudo nano /boot/cmdline.txt
Then delete console=serial0,115200 from the string.

Step 4. Reboot the Raspberry Pi3

sudo reboot

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------
pi@raspberrypi:~ $ git clone https://github.com/Seeed-Studio/ublox_l ... pi_hat.git
Cloning into 'ublox_lara_r2_pi_hat'...
remote: Counting objects: 60, done.
remote: Total 60 (delta 0), reused 0 (delta 0), pack-reused 60
Unpacking objects: 100% (60/60), done.
pi@raspberrypi:~ $ cd ublox_lara_r2_pi_hat
pi@raspberrypi:~/ublox_lara_r2_pi_hat $ sudo python setup.py install
running install
running bdist_egg
running egg_info
creating ublox_lara_r2.egg-info
writing requirements to ublox_lara_r2.egg-info/requires.txt
writing ublox_lara_r2.egg-info/PKG-INFO
writing top-level names to ublox_lara_r2.egg-info/top_level.txt
writing dependency_links to ublox_lara_r2.egg-info/dependency_links.txt
writing manifest file 'ublox_lara_r2.egg-info/SOURCES.txt'
reading manifest file 'ublox_lara_r2.egg-info/SOURCES.txt'
writing manifest file 'ublox_lara_r2.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-armv7l/egg
running install_lib
running build_py
creating build
creating build/lib.linux-armv7l-2.7
creating build/lib.linux-armv7l-2.7/ublox_lara_r2
copying ublox_lara_r2/__init__.py -> build/lib.linux-armv7l-2.7/ublox_lara_r2
copying ublox_lara_r2/ublox_lara_r2.py -> build/lib.linux-armv7l-2.7/ublox_lara_r2
creating build/bdist.linux-armv7l
creating build/bdist.linux-armv7l/egg
creating build/bdist.linux-armv7l/egg/ublox_lara_r2
copying build/lib.linux-armv7l-2.7/ublox_lara_r2/__init__.py -> build/bdist.linux-armv7l/egg/ublox_lara_r2
copying build/lib.linux-armv7l-2.7/ublox_lara_r2/ublox_lara_r2.py -> build/bdist.linux-armv7l/egg/ublox_lara_r2
byte-compiling build/bdist.linux-armv7l/egg/ublox_lara_r2/__init__.py to __init__.pyc
byte-compiling build/bdist.linux-armv7l/egg/ublox_lara_r2/ublox_lara_r2.py to ublox_lara_r2.pyc
creating build/bdist.linux-armv7l/egg/EGG-INFO
installing scripts to build/bdist.linux-armv7l/egg/EGG-INFO/scripts
running install_scripts
running build_scripts
creating build/scripts-2.7
copying bin/rpirtscts -> build/scripts-2.7
creating build/bdist.linux-armv7l/egg/EGG-INFO/scripts
copying build/scripts-2.7/rpirtscts -> build/bdist.linux-armv7l/egg/EGG-INFO/scripts
changing mode of build/bdist.linux-armv7l/egg/EGG-INFO/scripts/rpirtscts to 755
copying ublox_lara_r2.egg-info/PKG-INFO -> build/bdist.linux-armv7l/egg/EGG-INFO
copying ublox_lara_r2.egg-info/SOURCES.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
copying ublox_lara_r2.egg-info/dependency_links.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
copying ublox_lara_r2.egg-info/requires.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
copying ublox_lara_r2.egg-info/top_level.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
zip_safe flag not set; analyzing archive contents...
creating dist
creating 'dist/ublox_lara_r2-0.0.1-py2.7.egg' and adding 'build/bdist.linux-armv7l/egg' to it
removing 'build/bdist.linux-armv7l/egg' (and everything under it)
Processing ublox_lara_r2-0.0.1-py2.7.egg
Copying ublox_lara_r2-0.0.1-py2.7.egg to /usr/local/lib/python2.7/dist-packages
Adding ublox-lara-r2 0.0.1 to easy-install.pth file
Installing rpirtscts script to /usr/local/bin

Installed /usr/local/lib/python2.7/dist-packages/ublox_lara_r2-0.0.1-py2.7.egg
Processing dependencies for ublox-lara-r2==0.0.1
Searching for pyserial==3.2.1
Best match: pyserial 3.2.1
Adding pyserial 3.2.1 to easy-install.pth file

Using /usr/lib/python2.7/dist-packages
Finished processing dependencies for ublox-lara-r2==0.0.1
pi@raspberrypi:~/ublox_lara_r2_pi_hat $ cd test
pi@raspberrypi:~/ublox_lara_r2_pi_hat/test $ sudo python test01.py
assuming 40-pin GPIO header
Enabling CTS0 and RTS0 on GPIOs 16 and 17
rts cts on
waking up... ...


module name: LARA-R211
RSSI: 99
pi@raspberrypi:~/ublox_lara_r2_pi_hat/test $

Bill

cobbler.kave
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Wed Sep 12, 2018 8:33 pm
Location: Tampa, Florida

Re: LTE CAT1 hat (Europe version)

Post by cobbler.kave » Wed Sep 12, 2018 8:35 pm

Thanks, Bill! That was very helpful.

dp
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Wed Sep 26, 2018 5:42 am

Re: LTE CAT1 hat (Europe version)

Post by dp » Wed Sep 26, 2018 5:52 am

Hi,
everything with installation worked almost first time - good!
Modem works, is booked into the LTE network, reasonable RSSI.


Now - do I actually get a network device? How do I use the LTE IP-uplink?

ip a shows only the lo, eth0 and wlan0...

Thanks,
Dieter

bill.yu
Elementary-2
Elementary-2
Posts: 296
Joined: Mon Apr 02, 2018 11:05 am

Re: LTE CAT1 hat (Europe version)

Post by bill.yu » Fri Sep 28, 2018 5:36 pm

Hi there,

please take a look at https://www.u-blox.com/sites/default/fi ... 820%29.pdf thanks.

Post Reply