ReSpeaker 2-Mics PI-HAT

Applications/questions using Raspberry Pi with Seeed products, please post it here.

Moderators: violet, jessie, yexiaobo

Post Reply
feiticeir0
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Wed Mar 28, 2018 10:01 pm

ReSpeaker 2-Mics PI-HAT

Post by feiticeir0 » Wed Mar 28, 2018 10:11 pm

Hi all ! This is my first post !

I've purchased the ReSpeaker 2-Mics HAT for the Raspberry PI and would love to use it !
I've followed the instructions on the wiki - http://wiki.seeedstudio.com/ReSpeaker_2_Mics_Pi_HAT/ - everything run ok, but after a reboot, no seed sound card is present, like it is displayed on the tutorial.

Code: Select all

pi@raspberrypi:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 7/7
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
and no record device:

Code: Select all

pi@raspberrypi:~ $ arecord -l
**** List of CAPTURE Hardware Devices ****
pi@raspberrypi:~ $ 
I'm using a Raspberry PI Zero W and the latest version of raspbian - STRETCH

Any hint what could it be ?

feiticeir0
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Wed Mar 28, 2018 10:01 pm

Re: ReSpeaker 2-Mics PI-HAT

Post by feiticeir0 » Thu Mar 29, 2018 3:11 am

The error is kernel related - :

Your kernel headers for kernel 4.14.24-v7+ cannot be found at
/lib/modules/4.14.24-v7+/build or /lib/modules/4.14.24-v7+/source ??

jellyfish
Pre-kindergarten
Pre-kindergarten
Posts: 16
Joined: Fri Nov 09, 2012 9:31 am

Re: ReSpeaker 2-Mics PI-HAT

Post by jellyfish » Mon Apr 09, 2018 9:47 am

Hi Dear Customer, We see you already got the issue solved through github. We also updated the wiki and we tested it with rpi zero w with kernel 4.14.30 successfully.

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.14.30+ #1102 Mon Mar 26 16:20:05 BST 2018 armv6l GNU/Linux
pi@raspberrypi:~ $

Here are the instructions for the driver installation.

sudo apt-get update
sudo apt-get upgrade
git clone https://github.com/respeaker/seeed-voicecard.git
cd seeed-voicecard
sudo ./install.sh
reboot

thanks

Seeed Techsupport Team
---------------
Best Regards
Jelly

Seeed Techsupport Team

Post Reply