Wifly v2.0 static ip problem

Ardiuno Compatible shields

Moderators: lily.li, violet

Post Reply
homokyerik
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Mon Apr 08, 2019 2:29 am

Wifly v2.0 static ip problem

Post by homokyerik » Mon Apr 08, 2019 2:39 am

Hi guys, I'm experiencing some problem with wifly shield v2.0. I'm trying to set static ip address and than connect to some wlan but the problem appears during connecting to my computer's wlan. Wifly says that is properly connected but computer cannot see it and not showing any devices. The red led on shield blinks fast. But when I comment line with "set ip dhcp 0\r" it works properly. Any ideas? I would be happy for any response. Thank you

User avatar
bestlux
Kindergarten
Kindergarten
Posts: 85
Joined: Wed Jan 30, 2019 11:51 am

Re: Wifly v2.0 static ip problem

Post by bestlux » Tue Apr 09, 2019 3:09 pm

Hello,
I do not know what your wifi sharing method so I can not give you more advice, sometimes it is not shown in the hotspot software in dhcp mode.

homokyerik
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Mon Apr 08, 2019 2:29 am

Re: Wifly v2.0 static ip problem

Post by homokyerik » Wed Apr 10, 2019 12:54 am

bestlux wrote:
Tue Apr 09, 2019 3:09 pm
Hello,
I do not know what your wifi sharing method so I can not give you more advice, sometimes it is not shown in the hotspot software in dhcp mode.
Hi bestlux, thanks for your reply. Finally, I solved it by myself. I forgot to set gateway on the shield. With that option it works perfectly, only one wrong thing is that the WiFly Shield cannot be seen as connected device in my computer but worth it.

Hope it helps someone with similar problem in the future.

Post Reply