RFBee Firmware Error

wireless communication and related Bees.

Moderators: lily.li, violet, jessie

Post Reply
jmprice27
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Thu Jun 20, 2013 11:48 pm

RFBee Firmware Error

Post by jmprice27 » Thu Jun 20, 2013 11:59 pm

I recently got two RFBee's and I have having problems operating the radio on them. As i understand it the firmware on the RFBee is not so much firmware, as an Arduino sketch that must always be deployed on the rfbeefor the radio to communicate as described in the manual, and writing a new sketch to the rfbee will remove this firmware.

Under the belief that the "firmware" on the rfbee would not be erased, i wrote a new sketch to the rfbee, without understanding that this would remove the firmware. After realizing this, I tried to re-install the firmware; however, every version that I have found online creates compiler errors. I have found fixes such as changing the capitalization of config.h and changing wprogram.h to Arduino.h, but neither have worked. I have also tried compiling on Arduino 0023, 1.04, and 1.52, and received compiler errors, such as those below:

C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:129: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:130: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:131: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:132: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:133: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:139: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:140: error: 'byte' has not been declared
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:143: error: 'byte' has not been declared
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:143: error: 'byte' has not been declared
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:145: error: 'byte' has not been declared
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCx.h:147: error: 'byte' does not name a type
In file included from C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:24:
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCxCfg.h:31: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCxCfg.h:73: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/CCxCfg.h:474: error: 'byte' does not name a type
In file included from C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:25:
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/Spi.h:36: error: 'byte' has not been declared
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/Spi.h:37: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\/Spi.h:38: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp: In member function 'void CCX::PowerOnStartUp()':
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:39: error: 'class SPI' has no member named 'slaveSelect'
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:39: error: 'HIGH' was not declared in this scope
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:40: error: 'delayMicroseconds' was not declared in this scope
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:42: error: 'class SPI' has no member named 'slaveSelect'
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:42: error: 'LOW' was not declared in this scope
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:45: error: 'class SPI' has no member named 'slaveSelect'
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:48: error: 'class SPI' has no member named 'slaveSelect'
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:51: error: 'digitalRead' was not declared in this scope
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:53: error: 'class SPI' has no member named 'transfer'
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:58: error: 'digitalRead' was not declared in this scope
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:60: error: 'class SPI' has no member named 'slaveSelect'
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp: At global scope:
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:65: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:81: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:103: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:120: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:142: error: 'byte' does not name a type
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:159: error: variable or field 'Setup' declared void
C:\Users\Jack\Google Drive\Documents\Arduino\libraries\RFBee_v1_1\CCx.cpp:159: error: 'byte' was not declared in this scope

My plan for rfbees is for them to be microcontrollers that communicate with each other via radio, sending messages between and acting on logic within the atmega 168. I do not know whether i have perceived the rfbee's capabilities wrong.

Thank you for your help.

User avatar
Jacket Chen
Staff
Staff
Posts: 659
Joined: Thu Jun 21, 2012 4:25 pm
Are you a staff member of seeedstudio?: yes
Which products/projects are your favorite?: Seeeduino Shields
Location: China

Re: RFBee Firmware Error

Post by Jacket Chen » Fri Jun 21, 2013 9:44 am

Hey you can decompress the attachment to Arduino/library. And maybe you need delete the older files about RFBee(maybe they can't exist simultaneously ). And it works well under Arduino 1.0.4. Good luck.
Love little, love long.

jmprice27
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Thu Jun 20, 2013 11:48 pm

Re: RFBee Firmware Error

Post by jmprice27 » Fri Jun 21, 2013 11:48 pm

Thanks for your help, I was able to compile a sketch that used the library. However, I am somewhat confused as to how the RFBee communicates. As i understand, the sendDta method and receiveDta method are used to read data from the radio?

Also, I compiled and deployed the example included in the library. Does the Serial port initialized in the setup loop refer to the connection with the radio, or the tx/rx pins on the rfbee?

Thanks you

Post Reply