Cannot get sample code for EMG sensor to compile

Grove is a modulated, ready-to-use tool set.
Much like Lego, it takes a building block approach to assembling electronics.

Moderators: lily.li, violet, jeremy882, crail.lyu969

Post Reply
amadon.faul
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Sun Apr 24, 2016 2:01 pm

Cannot get sample code for EMG sensor to compile

Post by amadon.faul » Sun Apr 24, 2016 2:10 pm

I am trying to upload the Grove EMG sensor sample code to my arduino and I get the error "LED_Bar' does not name a type.
I tried commenting it out just to get it to upload and I get a cascade of other compile errors if I do that.

I don't have the LED bar or Base Shield. I have the output from the sensor board going to A0 and hooked VCC and GND up to the red and black wires respectively. I was planning on using my multi-meter to measure the output on D2 which I believe is where the LED bar would be attached using the base shield.

But anyway, despite not having the base and LED bar, I still don't understand why I can't even compile the sample code. I'm using Arduino IDE V. 1.6.7 but I also tried compiling it with Arduino IDE V. 1.0.6 and got the same problem.

Any suggestions?

kavi
Staff
Staff
Posts: 305
Joined: Tue Dec 09, 2014 12:06 pm

Re: Cannot get sample code for EMG sensor to compile

Post by kavi » Mon Apr 25, 2016 6:11 pm

Hi,

Please find the attached code which would compile with no errors.

Check the D8 and D9 ports to know the status of the LED bar.

Let us know if you have any other issues.

Thanks and Regards

Post Reply