LED Strip Driver not working with Wio LTE Tracker

Grove is a modulated, ready-to-use tool set.
Much like Lego, it takes a building block approach to assembling electronics.

Moderators: lily.li, violet, jeremy882, crail.lyu969

Post Reply
viperguynaz
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Thu Sep 05, 2019 2:51 am

LED Strip Driver not working with Wio LTE Tracker

Post by viperguynaz » Mon Sep 16, 2019 10:51 pm

I have the Grove LED Strip Driver plugged into D38 on the Wio LTE Cat M1/NB-IoT Tracker. Power is connected and the LEDs are on, but when I run the demos with the code setup - nothing happens:

Code: Select all

#include "RGBdriver.h"
#define CLK 2//pins definitions for the driver        
#define DIO 3
RGBdriver Driver(CLK,DIO);
I added logging to the demo and the loop is executing properly. Any ideas on how to get this to work?

bill.yu
Junior-7
Junior-7
Posts: 732
Joined: Mon Apr 02, 2018 11:05 am

Re: LED Strip Driver not working with Wio LTE Tracker

Post by bill.yu » Thu Sep 19, 2019 11:22 am

Hi there~

1. If you connect to D38, then you have to define the CLK and DIO as 38 and 39.

2. What kinds of LED do you use? thanks.

viperguynaz
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Thu Sep 05, 2019 2:51 am

Re: LED Strip Driver not working with Wio LTE Tracker

Post by viperguynaz » Fri Sep 20, 2019 9:51 am

Thanks Bill - I gave that a shot and it still doesn't work. I've tried a couple different generic RGB+ LED strips, but the result is the same with both. Here's the code I'm pushing...

Code: Select all

#include <board.h>

//  Author:Frankie.Chu 
//  Date:March 9,2012
//  This library is free software; you can redistribute it and/or
//  modify it under the terms of the GNU Lesser General Public
//  License as published by the Free Software Foundation; either
//  version 2.1 of the License, or (at your option) any later version.
//
//  This library is distributed in the hope that it will be useful,
//  but WITHOUT ANY WARRANTY; without even the implied warranty of
//  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
//  Lesser General Public License for more details.
//
//  You should have received a copy of the GNU Lesser General Public
//  License along with this library; if not, write to the Free Software
//  Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
/***************************************************************************/
#include "RGBdriver.h"
#define CLK 38  //pin definitions for the driver        
#define DIO 39
RGBdriver Driver(CLK,DIO);
void setup()  
{ 

}  
void loop()  
{ 
  Driver.begin(); // begin
  Driver.SetColor(0, 0, 0); //Red. first node data
  Driver.end();
  delay(5000);  Driver.begin(); // begin
  Driver.SetColor(255, 0, 0); //Red. first node data
  Driver.end();
  delay(5000);
  Driver.begin(); // begin
  Driver.SetColor(0, 255, 0); //Green. first node data
  Driver.end();
  delay(5000);
  Driver.begin(); // begin
  Driver.SetColor(0, 0, 255);//Blue. first node data
  Driver.end();
  delay(5000);
}

Any other ideas?

bill.yu
Junior-7
Junior-7
Posts: 732
Joined: Mon Apr 02, 2018 11:05 am

Re: LED Strip Driver not working with Wio LTE Tracker

Post by bill.yu » Mon Sep 23, 2019 6:17 pm

Hi there~

I do not have the RGB leds which matched with LED matrix driver on hands, But i have the ws2812 leds. I connected it to D38 and test it with below code successfully. thanks.

Code: Select all

#include "Seeed_ws2812.h"

#define LEN_NUM  20
#define LED_PIN  38

WS2812 strip = WS2812(LEN_NUM, LED_PIN);

void setup() {
  strip.begin();
  strip.brightness = 20;
}

void loop() {  
  strip.RGBCycle(1000);   
  strip.rainbowCycle(20);	
}

Post Reply