Grove Starter Kit with Arduino 1.0

Grove is a modulated, ready-to-use tool set.
Much like Lego, it takes a building block approach to assembling electronics.

Moderators: lily.li, violet, jeremy882, crail.lyu969

Post Reply
francusant
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Sat Jan 14, 2012 3:02 pm
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: I am Using the Grove Starter Bundle with the Arduino 1.0

Grove Starter Kit with Arduino 1.0

Post by francusant » Sat Jan 14, 2012 3:38 pm

Hello I just bought this kit about a week ago (my first kit ever!!) and just started playing around with it. So far I've managed to work the LED's, make it blink, change brightness, also worked with the potentiometer, and button, and the piezzo buzzer.

Now im moving to the LCD bu I'm having problems with the LCD screen displaying. Not sure what to do since I'm a newb :( .

This is my kit: http://www.seeedstudio.com/wiki/GROVE_- ... _Kit_V1.1b

I downloaded the SerialLCD_arduino_1.0_20120107.zip from (http://www.seeedstudio.com/wiki/index.p ... Serial_LCD) because my kit came with the arduino.
Ive downloaded and added this to the library per instructions.
(User/arduino-1.0/libraries/)(**my defaulf file**)

Im pulling up the example sketch "HelloWorld" from: User/arduino-1.0/libraries/SeriaLCD/examples/HelloWorld) The sketch compiles with no errors under the IDE and uploads to the arduino micro-controller also with no errors.... BUT the screen never turns on or displays anything....
I have the LCD screen connected to pin 11, and yes i restarted my IDE and reset the arduino, the Base Shield, and the LCD screen.
Not sure what to do next and I'm kind of lost, what should i do next??? Help please.

schmron
Elementary-1
Elementary-1
Posts: 145
Joined: Mon Dec 05, 2011 6:12 am

Re: Grove Starter Kit with Arduino 1.0

Post by schmron » Sun Jan 15, 2012 4:10 am

Did you change the LCD contrast? If contrast is to low you cant see anything on the LCD...
Best regards from Vienna/Austria
Rony

francusant
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Sat Jan 14, 2012 3:02 pm
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: I am Using the Grove Starter Bundle with the Arduino 1.0

Re: Grove Starter Kit with Arduino 1.0

Post by francusant » Mon Jan 16, 2012 9:06 am

no i have not!!! Ill try it right away and let you guys know.

francusant
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Sat Jan 14, 2012 3:02 pm
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: I am Using the Grove Starter Bundle with the Arduino 1.0

Re: Grove Starter Kit with Arduino 1.0

Post by francusant » Mon Jan 16, 2012 12:06 pm

OK I finally obtained the correct library to use with the 1.1b kit. Now i got it working.

aventao
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Wed Jan 25, 2012 6:05 am
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: newbie . starter Kit

Re: Grove Starter Kit with Arduino 1.0

Post by aventao » Wed Jan 25, 2012 6:08 am

I have the same problem, where are the correct libraire , :roll:


Thanks

I Solve IT, the problem are arduino 1.0 , with arduino 023 work perfect.
( if you have problems with drivers with windows 7 , drivers in arduino 1.00 are the best )

francusant
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Sat Jan 14, 2012 3:02 pm
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: I am Using the Grove Starter Bundle with the Arduino 1.0

Re: Grove Starter Kit with Arduino 1.0

Post by francusant » Sat Feb 11, 2012 11:05 am

I need help with how to display special characters in the LCD screen. Any help appreciated, or if you have and excerpt of code even better.
Thanks! :D

Post Reply