Noise on Arduino PWM pins?

Arduino, Seeeduino Serials and mutants. Share your problems and experence on arduino compatible board such as seeeduino/stalker, etc.

Moderators: lily.li, violet, salmanfarisvp

Post Reply
donkjr
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Wed Jun 20, 2012 11:05 am
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: SLD33149P

Noise on Arduino PWM pins?

Post by donkjr » Wed Jun 20, 2012 11:29 am

We are using the SLD33149P in a on stage demo next week.

We were in final test and ran into a wall and are in a panic.

Configuration:
Running arduino Uno
Using pins 5, 6 pwm to control x and y servos
We are commanding the servos from cell text through SLD shield to Arduino PWM pins.

Every time we poll for SMS messages the servos jerks like there is noise on the PWM's.
We disabled our servo code so we know that the PWM is not changing deliberately.
We disconnected the pins 5, 6 from the SLD card by bending them out from under the header and the problem remains. IE nothing from the Arduino is connected to these pins.

Arduino and sheild powered from USB but servos powered from external supply. All grounded to same point.

I seems like there is some kind of noise problem.

This exact problem shows up on two identical builds.

Any ideas. Does the SLD put anything on these pins? (checking the schematic after this), but the bent pin test would seem to invalidate this theory.

Desperately need help...

Tobe
Pre-kindergarten
Pre-kindergarten
Posts: 34
Joined: Tue Jan 17, 2012 11:04 am
Are you a staff member of seeedstudio?: yes
Which products/projects are your favorite?: Seeeduino

Re: Noise on Arduino PWM pins?

Post by Tobe » Wed Jun 20, 2012 4:59 pm

Try to use the external power on the GPRS shield too.the usb just power the Arduino Uno.

hextic
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Wed Jun 20, 2012 2:25 am
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: need tech support

Re: Noise on Arduino PWM pins?

Post by hextic » Thu Jun 21, 2012 12:12 am

I would guess a power draw issue too. Absent that, if you have another Arduino leave it there logging pulse width so you can measure what's going on from there, verify that you have a consistent pulse width. If it's consistent, it's power. If not, something is messing with your pwm pins.

donkjr
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Wed Jun 20, 2012 11:05 am
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: SLD33149P

Re: Noise on Arduino PWM pins?

Post by donkjr » Fri Jun 22, 2012 8:25 pm

It was not noise.
While polling for SMS the serial class, which now uses interrupts, caused the servo timer to periodically arrive late and extend the PWM pulse.
We detach the servo during polling, fixed.

Post Reply