Analog values with W5500 Ethernet Shield and Mega

Arduino, Seeeduino Serials and mutants. Share your problems and experence on arduino compatible board such as seeeduino/stalker, etc.

Moderators: violet, jessie

Post Reply
farrokh
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Mon Oct 22, 2018 5:08 pm

Analog values with W5500 Ethernet Shield and Mega

Post by farrokh » Sun Nov 25, 2018 1:56 am

hi,

I'm using an Arduino (italy) Mega with the Seeed W5500 Ethernet Shield for reading analog inputs from potentiometers.

The Card and shield are connecting OK -

Here's the problem -

On Analog pins 4 and 5 (on the shield) im seeing increased values as compared to the Mega (without shield) or, with my older Arduino 5500 Ethernet 2 card -

All Unused analog pins have been set to LOW (6,7,14,15)

Eg: the approx mid point of the pot on A4 shows a raw value of about 620 (+/- 1) when using the Seeed shield, and shows about 500 (+/- 1 ) when using the Arduino Ethernet2, or without the seeed shield

As i can see that the analog pins are just "connect thru" on the shield, i dont know why im seeing an increase in value/voltage...

Im using the Ethernet2 library.....

any suggestions?

Thanks...

fc

bill.yu
Elementary-3
Elementary-3
Posts: 354
Joined: Mon Apr 02, 2018 11:05 am

Re: Analog values with W5500 Ethernet Shield and Mega

Post by bill.yu » Fri Nov 30, 2018 5:31 pm

HI FC,
If you use the non-I2C analog port, the reading is the same with/without w5500 shield.

the w5500 is connected the a4/a5 with scl and sda.

for mega, the sda/scl are 20/21.

So i think the w5500 shorts the a4/a5 with scl and sda, then the pull up resistor impacts the readings. thanks.

oard I2C / TWI pins
Uno, Ethernet A4 (SDA), A5 (SCL)
Mega2560 20 (SDA), 21 (SCL)
Leonardo 2 (SDA), 3 (SCL)
Due 20 (SDA), 21 (SCL), SDA1, SCL1

farrokh
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Mon Oct 22, 2018 5:08 pm

Re: Analog values with W5500 Ethernet Shield and Mega

Post by farrokh » Mon Dec 03, 2018 12:28 pm

thanks bill

ill check it out

are you saying i should avoid using A5/A5 on the 5500 shield with the mega?

fc

bill.yu
Elementary-3
Elementary-3
Posts: 354
Joined: Mon Apr 02, 2018 11:05 am

Re: Analog values with W5500 Ethernet Shield and Mega

Post by bill.yu » Mon Dec 03, 2018 2:46 pm

Hi FC,

Please use the a0~a3, thanks.

Post Reply