Problems after burning FW AirM2M_Luat_V0011_W600T_USER

Have a question about Air602 WiFi Module? Ask here!

Moderators: lily.li, violet, qi.liao, jellyfish

Post Reply
tarp.andreas
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Mon Mar 26, 2018 7:06 pm

Problems after burning FW AirM2M_Luat_V0011_W600T_USER

Post by tarp.andreas » Sun Dec 02, 2018 11:16 pm

Hello,

it seems, that if one burns the AirM2M_Luat_V0011_W600T_USER.FLS Firmware as described in the Wiki, it is impossible to use the LuaTool
for that module again. I tried with several pieces of the Air602-Module. The burning process succeeds. After that, the module works as it should, except for the serial communication.
If I then try to load another Firmware (or the same again), the process stops after a few seconds.(Yes, I repeated step 5 many many times....)
The problem seems to be with the serial communication. Before upgrading I connected with picocom from Linux and with putty
from Windows. Everything was fine. Now I can only connect from the command line: echo -e 'at+' >/dev/ttyUSB0
I then catch the output from another console with cat < /dev/ttyUSB0
It seems that the module now needs a CR (0D) just after the AT-command. I.e. echo -ne 'at+' >/dev/ttyUSB0 fails but
echo -ne 'at+\r' >/dev/ttyUSB0 does not.
I couldn't find out where to configure picocom or putty to put in the CR for me. And I believe that the problem with the LuaTool has the same reason.
P.S.: The AirM2M_Luat_V0010_W600T_USER.img, which I tried first, worked as it should - but know I can't go back again :-(

User avatar
jellyfish
Pre-kindergarten
Pre-kindergarten
Posts: 29
Joined: Fri Nov 09, 2012 9:31 am

Re: Problems after burning FW AirM2M_Luat_V0011_W600T_USER

Post by jellyfish » Fri Dec 07, 2018 11:31 am

Hi andreas,

Sorry for the late reply.

If your air602 still can accept AT command , please follow the instruction below.

Step 1.

Send the command via serial tool below to enter the flash write mode:

Code: Select all

AT+&FLSW=5000,11
Step 2. Close the serial port in the serial tool, then use the Luat_Tool to download the AirM2M_Luat_V0010_W600T_USER.FLS(maybe you shuould download it twice)

Now you can use the firmware V08 or V09 or V10.

Image

If your air602 can not accept AT command , you should pull pin PA0(GPIO13) to ground before you power this module.

Then you can use Luat_Tool to download the AirM2M_Luat_V0010_W600T_USER.FLS(maybe you shuould download it twice)



You can find the AirM2M_Luat_V0010_W600T_USER.FLS here

https://github.com/SeeedDocument/Air602 ... 02_img.zip
---------------
Best Regards
Jelly

Seeed Techsupport Team

tarp.andreas
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Mon Mar 26, 2018 7:06 pm

Re: Problems after burning FW AirM2M_Luat_V0011_W600T_USER

Post by tarp.andreas » Sun Dec 09, 2018 3:01 am

Hello Jelly,

thank you for your reply!
I followed step 1. and 2. and now I can download the firmware again.
But... the module stays in download mode, sending ASCII "C" and ignoring any AT commands.
When I press the reset button the output changes to "Q" for a short period, then it sends "C" again.
After

Code: Select all

AT+&
it stops sending "C" but still doesn't respond to AT commands.
How can I leave the download mode?
Are there other

Code: Select all

AT+&...
commands? The official document only describes AT+...
commands without ampersand :idea:

Best regards

Andreas

Post Reply