Error: Network initialize timeout in Wio LTE Cat M1/NB-IoT Tracker

I have recently bought Wio LTE Cat M1/NB-IoT Tracker. i worked on Grove sensors, GNSS and on board RGB LED all are working fine.

but when i insert the 4G vodafone SIM and run the RSSI example code, Ublox gets powered on and also SIM is detected whereas Network initialization is failed.

Do I need to have LTE CAT M1 enabled for my SIM card ?? or is it necessary that the LTE Cat M1 network is implimented in my area of testing?

I am located in Bengaluru, India, 560001



Serial data from Unit:



…[ERROR] Network initialize timeout.



…[ERROR] Network initialize timeout.



…[ERROR] Network initialize timeout.



…[ERROR] Network initialize timeout.



…[ERROR] Network initialize timeout.



…[ERROR] Network initialize timeout.



hope to get the reply soon, Thanks in advance

Hi Rahman , Can you please share your sketch , to get more deatils.



Thanks .

Below is the RSSI Example code.

=======================================================================================================

#include <ublox_sara_r4.h>

#include <UART_Interface.h>



Ublox_sara_r4 ublox = Ublox_sara_r4();



void setup() {



SerialDebug.println(“Begin…”);

ublox.powerOn();

SerialDebug.print(“Waitting for module to alvie…”);

while(false == ublox.isAlive()){

SerialDebug.print(".");

delay(100);

}



while(!ublox.network_Init(30000)) { // changed t0 180 i.e nearly 3 mins

Log_error(“Network initialize timeout.”);

}

Log_info("APN: " + String(ublox._apn));

Log_info("Local IP: " + String(ublox._str_ip));

Log_info("Operator: " + String(ublox._operator));

Log_info(“Network attached.”);

}



void loop() {

int signal;

if(ublox.getSignalStrength(&signal)) {

SerialDebug.print("RSSI: ");

SerialDebug.println(signal, DEC);

} else {

SerialDebug.print(“Error”);

}



delay(1000);

}

===============================================================================================

i m using the WioLTE_Cat_NB1_Arduino_Library from Github.

check out the link: <LINK_TEXT text=“https://github.com/lanselambor/WioLTE_C … no_Library”>https://github.com/lanselambor/WioLTE_Cat_NB1_Arduino_Library</LINK_TEXT>



what if i use hologram sim?? will it solve the problem?? is there any changes required in the source code??

i have tried this code at my Clients Location (i.e.ATLANTA, US) with T-Mobile NB-IOT SIM still the same error takes place.But when i dumped the same code in WIO LTE CAT.NB-IOT(SARA-N410) module with the same SIM, it got successfully registered and we are able to publish the MQTT Packets.

Is there any issue with Wio LTE Cat M1/NB-IoT Tracker??