arecord: main:788: audio open error: Device or resource busy


I am using a Raspberry Pi 3 Model B Rev 1.2 board and would like to interface ReSpeaker Mic Array v2.0, ReSpeaker 4-Mic Array, ReSpeaker 4-Mic Linear Array and ReSpeaker 6-Mic Circular Array with it. Out of the mentioned 4, I could get only the v2.0 working effectively. I have followed every instructions of the Getting Started manual for all but every time I use “arecord -Dac108 -f S32_LE -r 16000 -c 8 a.wav” it outputs “arecord: main:788: audio open error: Device or resource busy” this error. The arecord and aplay works well otherwise (for internal audio in/out), aplay works with all the mentioned arrays the issue I have is only with the arecord command. I did try providing hw ids “arecord -D hw:1,0 -f S32_LE -r 16000 -c 8 to_be_record.wav” but i get the same error message.

When i type in arecord -L and aplay -L, I can see the configs well but it just dosent work.

I would really appreciate if someone could help me with this issue.

Thanks in advance,


Hi Kavya

we suspect the mics are occupied by other resources. please run ps -A to see if any arecord process and then use the kill -9 PID to kill. please let us know if the issue is not solved. thanks.

1 Like


When I try to test my connected USB mic using the command given in the lecture, I get the following error

“arecord: main:788: audio open error: Device or resource busy”

Please help me… I am using a USB mic & 3.5mm speaker is connected to the 3.5mm audio jack.

Pl note that mic is detected by pi.

Also, when I run ps -A nothing else is using my USB mic

Thank You,


Was this fixed anytime?

I’m having the same issue. Exactly the same.
arecord outputs me this:
“arecord: main:788: audio open error: Device or resource busy”
I don’t find anything running the mic with ps -A

Please help me