Search found 8 matches

by volodymyr.strakh
Sat Nov 16, 2019 10:56 pm
Forum: Shields
Topic: Spartan Edge Accelerator Arduino header
Replies: 2
Views: 158

Re: Spartan Edge Accelerator Arduino header

Well, SEA is the arduino shield. And the vast majority of arduinos out there is 5v, so ... If you need PMOD and 3.3v vccio - SEA isn't the product you should be choosing :) There's still room for 3.3v io. Fpga io's 0 to 9 is connected directly, so can act as inputs, or host one 8-line PMOD. Arduino ...
by volodymyr.strakh
Thu Nov 07, 2019 4:59 pm
Forum: Shields
Topic: Spartan Edge Accelerator Schematic
Replies: 2
Views: 640

Re: Spartan Edge Accelerator Schematic

Any reasons the AR_D12 / FPGA_AR_D12 is treated differently than the other digital io's that connected to FPGA? It's even highlighted on the schematic with magenta rectangle, but there's no comments around. All the digital pins has 1K/2K divider, but AR_D12 has weaker 10K/20K, like it's going into E...
by volodymyr.strakh
Sun Nov 03, 2019 1:28 am
Forum: Shields
Topic: Spartan Edge Accelerator standalone startup
Replies: 1
Views: 406

Re: Spartan Edge Accelerator standalone startup

Ok, it's not about ESP32 startup. I was watching the FPGA_DONE led to see when fpga will be configured, and it never did upon startup. So I concluded (incorrectly) ESP is at fault, not starting properly. I had no other suspects, because as soon as I connect to uart with some terminal app, I see the ...
by volodymyr.strakh
Fri Nov 01, 2019 6:15 pm
Forum: Shields
Topic: Spartan Edge Accelerator standalone startup
Replies: 1
Views: 406

Spartan Edge Accelerator standalone startup

Hi. It seems the ESP32 doesn't start automatically on power up. It does start after quite a few presses on RST button. But it looks like it starts immediately when terminal app is connected to the usb-uart port. I've tried both - powering via usb cable from a laptop usb port or from a charger, and u...
by volodymyr.strakh
Thu Oct 31, 2019 2:43 pm
Forum: Shields
Topic: Spartan Edge Accelerator SD card not mounting
Replies: 5
Views: 705

Re: Spartan Edge Accelerator SD card not mounting

That's not a factor in my tests, because all the cards I've tried were pre-formatted at factory as FAT32. When some card failed as FAT32 I tried to create 2GB FAT16 partition. Mounting/reading that card fails exactly the same, no matter if it was FAT32 or FAT16 partition. It feels more like a physic...
by volodymyr.strakh
Thu Oct 31, 2019 12:06 am
Forum: Shields
Topic: Spartan Edge Accelerator SD card not mounting
Replies: 5
Views: 705

Re: Spartan Edge Accelerator SD card not mounting

Ok, somehow the behavior depends very much on the exact card being used. It failed with 32GB cards, multiple trusted brands, all failed to mount. Working ok with laptop/phone. It mounted 16GB card speed class 4, but failed to read the data, giving same errors as in 595355940 's example. For the note...
by volodymyr.strakh
Wed Oct 30, 2019 10:36 pm
Forum: Shields
Topic: Spartan Edge Accelerator SD card not mounting
Replies: 5
Views: 705

Re: Spartan Edge Accelerator SD card not mounting

Randomly passing the initialization stage didn't save you from failing to read data block in the next request, isn't it?
I do believe it's possible, sometimes. But that's not a solution :)
by volodymyr.strakh
Wed Oct 30, 2019 2:41 am
Forum: Shields
Topic: Spartan Edge Accelerator SD card not mounting
Replies: 5
Views: 705

Spartan Edge Accelerator SD card not mounting

Hi. I've got my SEA board, but can't even test if it's functioning properly. I followed the "Getting started" article, trying to run the board in Arduino Shield mode. The example sketch in Arduino IDE did build without errors, and was flashed seemingly ok, yet the fpga side didn't change its state. ...