wio-cli failed

Simplify IoT Development.

Moderators: violet, yexiaobo, seth.welday

Post Reply
michael.lankers
Pre-kindergarten
Pre-kindergarten
Posts: 8
Joined: Wed May 04, 2016 2:30 am
Location: Geldern, Germany

wio-cli failed

Post by michael.lankers » Mon May 16, 2016 6:30 pm

Hi,

i spend hours to get it run on a raspberry3

I followed the instruction in the wiki but i get this errors:
pi@raspberrypi:~ $ wio --help
Traceback (most recent call last):
File "/usr/local/bin/wio", line 7, in <module>
from wio.wio import cli
File "/usr/local/lib/python2.7/dist-packages/wio/wio.py", line 14, in <module>
from requests.packages.urllib3.exceptions import InsecureRequestWarning
ImportError: cannot import name InsecureRequestWarning
:evil:

teng.wang
Pre-kindergarten
Pre-kindergarten
Posts: 37
Joined: Fri Apr 08, 2016 10:50 am

Re: wio-cli failed

Post by teng.wang » Mon May 16, 2016 8:48 pm

michael.lankers wrote:Hi,

i spend hours to get it run on a raspberry3

I followed the instruction in the wiki but i get this errors:
pi@raspberrypi:~ $ wio --help
Traceback (most recent call last):
File "/usr/local/bin/wio", line 7, in <module>
from wio.wio import cli
File "/usr/local/lib/python2.7/dist-packages/wio/wio.py", line 14, in <module>
from requests.packages.urllib3.exceptions import InsecureRequestWarning
ImportError: cannot import name InsecureRequestWarning
:evil:
@michael, can you tell me your Raspberry3 system version, and your python version?

michael.lankers
Pre-kindergarten
Pre-kindergarten
Posts: 8
Joined: Wed May 04, 2016 2:30 am
Location: Geldern, Germany

Re: wio-cli failed

Post by michael.lankers » Mon May 16, 2016 11:05 pm

Hi Teng,

i running the latest raspian distro

with Kernel 4.4.9 and
Python2.7.9

best regards

Michael

teng.wang
Pre-kindergarten
Pre-kindergarten
Posts: 37
Joined: Fri Apr 08, 2016 10:50 am

Re: wio-cli failed

Post by teng.wang » Tue May 17, 2016 11:00 am

@Michael
I do not have raspberry pie 3 currently, but there is no problem with ubuntu.

Can you try upgrade the wio-cli.
$sudo pip install wio-cli --upgrade
$wio --version
Now the latest version is v0.0.30

sheepjms
Pre-kindergarten
Pre-kindergarten
Posts: 15
Joined: Mon May 09, 2016 5:41 pm

Re: wio-cli failed

Post by sheepjms » Tue May 17, 2016 11:26 am

Maybe this will help for the same problem: https://github.com/diraimondo/gmusicproxy/issues/35

Post Reply