Page 1 of 1

Weird LoRawan behavior observed with spectrum analyzer

Posted: Wed May 09, 2018 12:05 pm
by sebastian.barillaro
Today I have did some testing: Node: FiPy ABP transmitting a byte, blink immediately led for debugging after sending, listening for receiving, repeat every 10 seconds.
Gateway: RisingHF.
Both connected end to end with a coaxial wire (no antenna) and the wire also connected to an spectrum analyzer for sniffing with a T connector.

What I observed is strange:
1) There are some 8 seconds between the node blinks (sending) and some activity is observed on Spectrum Analyzer.
2) There are some 10 seconds between the activity observed on Spectrum Analyzer and the gateway shows that the package was received on internal web-interface.
3) Even with direct connection through the coaxial wire, there are wide values of RSSI from -6 to -117.
4) Even that, there are some packages that never are received (or shown as received) on gateway web interface.

Help!

Re: Weird LoRawan behavior observed with spectrum analyzer

Posted: Tue May 15, 2018 1:36 am
by sebastian.barillaro
Hello!

I was told in other others forum (with much more manufacture's support) that SeeedStudio Gateway with RisingHF RHF0M301-915 is not able to use all 64 channels described in LoRaWAN specification. Just 8 of them. This is called Hybrid mode.

So I need to set up my nodes on same sub-channel that the Gateway is listening to. My question is what is the sub-set of channels that the Gateway is listening to.

With best regards

Sebastian Barillaro