DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes)

--DSO203

Moderators: violet, jessie, jpa

dida.poli
Pre-kindergarten
Pre-kindergarten
Posts: 5
Joined: Thu May 12, 2016 3:20 am

Hardware 2.82 FPGA configuration error

Post by dida.poli » Fri May 13, 2016 9:02 pm

Thank you very much WC.

Your advice was right.
I went to my neighbour, who has a computer running windows 10.
I uploaded FPGA_281.ADR, 281_FPGA.BIN and app1.hex from WC6.0.
5 minutes and the problem was solved.

Bye
Dida

borland
Kindergarten
Kindergarten
Posts: 50
Joined: Sun Mar 15, 2015 2:47 am

Re: Hardware 2.82 FPGA configuration error

Post by borland » Sun May 15, 2016 12:04 am

dida.poli wrote:Thank you very much WC.

Your advice was right.
I went to my neighbour, who has a computer running windows 10.
I uploaded FPGA_281.ADR, 281_FPGA.BIN and app1.hex from WC6.0.
5 minutes and the problem was solved.

Bye
Dida
I realize you have HW2.82, but it looks like your problem was initiated using Windows File Explorer in Win XP to install WC FPGA1.1. Is this correct?

I had just the opposite experience with HW2.81. My SYS was corrupted by using Window 10 to install WC's FPGA1.0.bin in DFU mode (DFU 3.45C), then restored using Windows XP.

dida.poli
Pre-kindergarten
Pre-kindergarten
Posts: 5
Joined: Thu May 12, 2016 3:20 am

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Post by dida.poli » Mon May 16, 2016 6:24 pm

I realize you have HW2.82, but it looks like your problem was initiated using Windows File Explorer in Win XP to install WC FPGA1.1. Is this correct?

I had just the opposite experience with HW2.81. My SYS was corrupted by using Window 10 to install WC's FPGA1.0.bin in DFU mode (DFU 3.45C), then restored using Windows XP.
DSO:
Hardware 2.82
SYS: 1.64
DFU: V3.46C
FPGA: V1.1 (File: 281_FPGA.BIN)

Host OS:
Windows XP Professional
Version 2002
Service Pack 3
copy by windows file exploerer
=> runs on VirtualBox 4.3.36 Ubuntu 14.04 64bit

Before I got trouble with "fpga configuration error", I had tried to upload firmware wc4.4, 5.1 and 6.0. Uploading app1.hex always resulted in app1.err. Therefore I tried the stuff with a new FPGA upload.

BUT!!

I have an additional DSO 203 which had smoked on short circuit against mass. :x
That DSO was HW 2.81. Ugrading to WC4.4 simply had needed to copy app1.hex. I had used the same XP machine.
There had been no problem. First try for success. :)
Last edited by dida.poli on Wed May 18, 2016 3:58 pm, edited 2 times in total.

muslimens
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Mon May 16, 2016 7:12 pm

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Post by muslimens » Mon May 16, 2016 7:23 pm

Dear dida.poli
I just get my new DSO203 version 2.82
Would you please give me step by step guide how to flash last realize of WC firmware (6.0)?
Thank you!

muslimens
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Mon May 16, 2016 7:12 pm

Re: Hardware 2.82 FPGA configuration error

Post by muslimens » Mon May 16, 2016 7:29 pm

borland wrote:
dida.poli wrote:Thank you very much WC.

Your advice was right.
I went to my neighbour, who has a computer running windows 10.
I uploaded FPGA_281.ADR, 281_FPGA.BIN and app1.hex from WC6.0.
5 minutes and the problem was solved.

Bye
Dida
Dear dida.poli
I just get my new DSO203 version 2.82
Would you please give me step by step guide how to flash last realize of WC firmware (WC 6.0)?
Thank you!

muslimens
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Mon May 16, 2016 7:12 pm

Re: Hardware 2.82: FGPA configuration error

Post by muslimens » Mon May 16, 2016 10:01 pm

Wildcat wrote:
dida.poli wrote:Hi

I bought a brand new DSO203: Hardware 2.82, SYS Ver 1.64, Serial No 792BD89A).
I tried to install Wildcat Version 5.1 => but uploading app1.hex via DFU results in app1.err.
So I uploaded FPGA_281.ADR, 281_FPGA.BIN and app1.hex (all Wildcat 5.1)=> uploading is perfectly done => but restarting dso hangs in splash screen showing "FGPA configuration error"
After that I tried these configurations without success:
- WC5.1: http://www.seeedstudio.com/forum/downlo ... hp?id=2339
- WC4.4: http://www.seeedstudio.com/forum ... mp;start=400#p21988
- http://www.seeedstudio.com/wiki/ ... mware#Firmware_List
- WC 6.0
- Original: http://www.minidso.com/forum.php?mod=vi ... a=page%3D1

Do you have any hints to go back to the original firmware or to get a matching FPGA File to use WC?

Thanks a lot for help
Dida
I have no way of verifying operation on devices other than up to 2.81, neither can I find any info on HW 2.82

Some suggestions:

-Older versions of Windows (XP, 7) seem to be more reliable for upgrading. What is the DFU version ? (shows on screen when updating). Later versions of Windows are fussy as to which version the DFU is. Also it's been reported that turning on the device before plugging in the USB is more reliable on later Win versions.

-A directory on your PC screen shows both app1 and FPGA being updated. I have always updated the APP and FPGA separately, shutting off the device and re-connecting the USB in between. It appears that you updated BOTH APP and FPGA at the same time. I don't know if there is a problem in doing this, I have just never tried it. You may want to try just uploading the APP hex file, then disconnecting and then starting over again and upload the ADR file, wait for the volume to reappear then copying the FPGA BIN file.

-Use Wildcat version 6.0 rather than 5.0 or 5.1, there have been some issues with versions 5 when used on HW2.81.
Dear WILDCAT
I have DSO203 and I need functionality from it... Like FFT...
Would you please give me advise which firmware fit for it and step by step guide for FIRMWARE update?
my mail is: muslimens(at)gmail(dot)com
Thank you!

dida.poli
Pre-kindergarten
Pre-kindergarten
Posts: 5
Joined: Thu May 12, 2016 3:20 am

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Post by dida.poli » Tue May 17, 2016 3:21 am

@muslimens

Worked for me with "Windows 10" but not with Windows XP
  • Download WC 6.0: http://www.seeedstudio.com/forum/downlo ... hp?id=2488
  • unzip it
  • open file explorer an change where you unzipped WC 6.0
  • switch your dso off
  • Hold >[] Button (most left button) while switching DSO on. => Screen shows "... The DFU Virtual USB Disk" (last of four lines)
  • connect dso to computer with usb cable => (waiting some seconds ...) new drive letter will appear
  • copy app1.hex from unzipped directory to this new drive => new drive will disappear for a moment
  • new drive will reappear. => you will see app1.rdy (if you see app1.err something went wrong)
  • switch dso off and on => :)

muslimens
Pre-kindergarten
Pre-kindergarten
Posts: 4
Joined: Mon May 16, 2016 7:12 pm

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Post by muslimens » Tue May 17, 2016 3:23 pm

dida.poli wrote:@muslimens

Worked for me with "Windows 10" but not with Windows XP
  • Download WC 6.0: http://www.seeedstudio.com/forum/downlo ... hp?id=2488
  • unzip it
  • open file explorer an change where you unzipped WC 6.0
  • switch your dso off
  • Hold >[] Button (most left button) while switching DSO on. => Screen shows "... The DFU Virtual USB Disk" (last of four lines)
  • connect dso to computer with usb cable => (waiting some seconds ...) new drive letter will appear
  • copy app1.hex from unzipped directory to this new drive => new drive will disappear for a moment
  • new drive will reappear. => you will see app1.rdy (if you see app1.err something went wrong)
  • switch dso off and on => :)
Hello dida!
Thanks for reply!
1) You told me " copy app1.hex " - just only 1 file from that big folder..... that is enough ?
2) And what happens if I saw " app1.err " - my device became bricked? Could I restore it in such case?
Thanks again!

dida.poli
Pre-kindergarten
Pre-kindergarten
Posts: 5
Joined: Thu May 12, 2016 3:20 am

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Post by dida.poli » Wed May 18, 2016 3:51 pm

@muslimens

1) Yes. The rest is for advanced use. (to program additional features to WC e.g.)
2.) estimate:
  • 95%: no changes => the old firmware works
  • 4%: same problem as me => try another way to reconfigure (see man y examples here in this thread)
  • 0.9%: get some help to reconfigure
  • 0.09%: get some special help to reconfigure
  • 0.01%: bricked

ThomasCaspari
Pre-kindergarten
Pre-kindergarten
Posts: 8
Joined: Sun Sep 20, 2015 5:38 pm

Re: DSO203 GCC APP - Community Edition (2.51+SmTech1.8+Fixes

Post by ThomasCaspari » Thu May 19, 2016 1:03 am

Dear folks,

just wanted to report a minor bug I came across in wc3.4 and wc5.1 (just updated to 5.1 - fantastic work wildcat!!!).

My setup:
HW 2.70 with DFU 3.11C, sys 1.52, alterbios 0.4 (stock except alterbios)

Minor bug I just found:
When in "A&B" trigger mode, signal sometimes freezes (Ch.B) or zeroes (Ch.A). Solution is: leave "A&B" trigger mode and enter it again.

How to reproduce:
- input signal, e.g. wave out (easy to reproduce this way)
- cut input signal (for testing: set wave out to "OFF") and reactivate again

after a few tries (in quite some cases after first try) channel A shows flat line / channel B freezes display

Leave "A&B" trigger mode and enter it again: everything is fine again.

Just wanted to report this, but is not a big problem.

Cheers

Thomas

Post Reply